Opened 5 years ago

Closed 5 years ago

Last modified 12 months ago

#10614 closed bug (fixed)

Radeon_hd cards non-functional on 64-bit

Reported by: vidrep Owned by: kallisti5
Priority: high Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10536
Has a Patch: no Platform: All

Description

Write hrev46950_x86_64 to USB stick within a4.1 Shutdown (64 bit has warm boot issue) Reboot All icons light Black screen (no signal) Serial debug log and listdev attached Have tested the following Radeon cardsas not working on 64 bit: HD2400, HD2600, HD3450, HD3550

Attachments (2)

hrev46950_x86_64_debug_log.txt (96.2 KB) - added by vidrep 5 years ago.
listdev_HD2400 (3.0 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by vidrep

Changed 5 years ago by vidrep

Attachment: listdev_HD2400 added

comment:1 Changed 5 years ago by luroh

Blocking: 7665 added

comment:2 Changed 5 years ago by vidrep

Tried hrev46955 using CD ISO image and Radeon card - same symptoms as described in ticket. Substitute Nvidia GeForce 8400 card - video working and installation to HDD proceeds normally. I have repeated this several times with the same result .

comment:3 Changed 5 years ago by pulkomandy

Blocking: 10536 added

comment:4 Changed 5 years ago by kallisti5

I can confirm seeing this on my system as well. I accidently started troubleshooting it as part of a more general PLL calculation issue :-)

The problem is here:

2008	radeon_hd: pll_compute: using minimum reference divider
2009	radeon_hd: pll_compute: performing fractional feedback calculations
2010	radeon_hd: pll_compute: Calculated pixel clock of 15 based on:
2011	radeon_hd: pll_compute:   referenceFrequency: 1010; referenceDivider: 1025
2012	radeon_hd: pll_compute:   feedbackDivider: 2048; feedbackDividerFrac: 0
2013	radeon_hd: pll_compute:   postDivider: 127
2014	radeon_hd: pll_compute: pixel clock 148500 was changed to 15

Your (and my) pixel clock is getting greatly reduced. This looks to be due to the referenceFrequency of "1010" (101 really is what it is pulling as referenceFrequency is * 10.

1010 really isn't valid.

On my card under x86_64 I dumped my AtomBIOS and the reference frequency is "2700", however atombios gets 1 at http://cgit.haiku-os.org/haiku/tree/src/add-ons/accelerants/radeon_hd/pll.cpp#n98...

KERN: radeon_hd: pll_compute: performing fractional feedback calculations
KERN: radeon_hd: pll_compute: Calculated pixel clock of 9 based on:
KERN: radeon_hd: pll_compute:   referenceFrequency: 10; referenceDivider: 1025
KERN: radeon_hd: pll_compute:   feedbackDivider: 2048; feedbackDividerFrac: 0
KERN: radeon_hd: pll_compute:   postDivider: 2
KERN: radeon_hd: pll_compute: pixel clock 148500 was changed to 9

Most likely due to a type issue somewhere... no idea where though. Maybe somewhere in our AtomBIOS.

comment:5 Changed 5 years ago by kallisti5

Component: - GeneralDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5
Priority: normalhigh
Summary: Radeon cards black screen on 64 bit hrev46950Radeon_hd cards non-functional on 64-bit

comment:6 Changed 5 years ago by vidrep

Installed hrev47847 to hard drive partition. Confirmed Radeon HD2400 (RV610 IGP), HD3450 (RV620), and HD3550 (RV620) all working at native 1920x1080 resolution. I believe this ticket can be closed now.

comment:7 Changed 5 years ago by luroh

Resolution: fixed
Status: newclosed

Thanks!

comment:8 Changed 12 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.