Opened 6 years ago

Closed 5 years ago

Last modified 16 months ago

#10750 closed bug (duplicate)

Can't boot from USB3 port: "PANIC: did not find any boot partitions!" on hrev47105-x86gcc2hybrid-anyboot

Reported by: ivanov Owned by: mmlr
Priority: normal Milestone: R1/beta1
Component: Drivers/USB Version: R1/Development
Keywords: Cc:
Blocked By: #8954 Blocking: #10749
Has a Patch: no Platform: All

Description

Image of the full error is here: http://imgur.com/jDLyWBr, this is on Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz

This is a possible duplicate of #8652 and #8646, but on hrev47105

In one of those, the output of lspci was suggested, so here's that:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2200 (rev c4)
04:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)

Attachments (1)

tmp_boot_PANIC_samsung_nc10.jpg1563997514.jpg (1.5 MB ) - added by taos 5 years ago.
Boot PANIC from Samsung NC10 using hrev47259-x86gcc2hybrid-anyboot.

Download all attachments as: .zip

Change History (16)

comment:1 by pulkomandy, 6 years ago

over IRC: this was booting an anyboot image from USB. It's likely because we don't handle xHCI ports yet?

comment:2 by ivanov, 6 years ago

As @pulkomandy suggested on IRC, this was indeed an issue with trying to boot from a USB3 port. Using a USB2 port resolved the issue and I was able to booth. Seems like this is a known issue, though I hope someone makes a note of it on the "making a usb stick" page on haiku-os.org installation instructions.

comment:3 by pulkomandy, 6 years ago

Summary: "PANIC: did not find any boot partitions!" on hrev47105-x86gcc2hybrid-anybootCan't boot from USB3 port: "PANIC: did not find any boot partitions!" on hrev47105-x86gcc2hybrid-anyboot

comment:4 by anevilyak, 6 years ago

Blocking: 10749 added

(In #10749) Double post of #10750 (which has more information).

comment:5 by luroh, 5 years ago

Blocking: 7665 added

comment:6 by waddlesplash, 5 years ago

Component: - GeneralDrivers/USB
Milestone: R1R1/alpha5
Owner: changed from nobody to mmlr
Priority: normalcritical

I'd like this to get resolved by R1a5, but I'm guessing it's quite involved... Any kernel developers want to take a stab at it?

comment:7 by mmadia, 5 years ago

Priority: criticalnormal

comment:8 by jessicah, 5 years ago

Blocked By: 8954 added

by taos, 5 years ago

Boot PANIC from Samsung NC10 using hrev47259-x86gcc2hybrid-anyboot.

comment:9 by taos, 5 years ago

You might find it interesting to know that I get an almost identical PANIC (see attached jpg file) when booting hrev47259-x86gcc2hybrid-anyboot from usb on a Samsung NC10 - that's an Atom N270 equipped netbook without any usb3 ports.

hrevr1alpha4-44619 boots fine (same for alpha 2 and 3, so that's in contrast to similar problems reported in #8652 or #5983).

listdev output from alpha4 doesn't mention XHCI, only EHCI, and UHCI, see excerpt:

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 27cc: NM10/ICH7 Family USB2 EHCI Controller

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 27cb: NM10/ICH7 Family USB UHCI Controller #4

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 27ca: NM10/ICH7 Family USB UHCI Controller #3

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 27c9: NM10/ICH7 Family USB UHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 27c8: NM10/ICH7 Family USB UHCI Controller #1

lspci output:

00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)

I'm not sure if the provided information is relevant here. Should I open a new ticket or add this information to one of the older tickets?

comment:10 by jessicah, 5 years ago

Can you please re-test with hrev45934-anyboot and hrev45929-anyboot?

This will confirm whether it's an XHCI or MSI problem in the USB code.

EDIT: updated to correct hrevs.

Last edited 5 years ago by jessicah (previous) (diff)

comment:11 by taos, 5 years ago

I can test with those revisions later. However, I found out that in my case the problem is relateted to an optical usb mouse:

  • plugged in before booting -> PANIC message
  • not plugged in during boot -> no PANIC message, Haiku boots fine, mouse works
  • plugged in after first three icons in Haiku boot sequence light up -> no PANIC, everything works

Update: It's the same for both hrev45934-anyboot and hrev45929-anyboot.

Last edited 5 years ago by taos (previous) (diff)

in reply to:  9 comment:12 by umccullough, 5 years ago

Replying to taos:

You might find it interesting to know that I get an almost identical PANIC (see attached jpg file) when booting hrev47259-x86gcc2hybrid-anyboot from usb on a Samsung NC10 - that's an Atom N270 equipped netbook without any usb3 ports.

Actually, it's not an uncommon panic, and it's actually quite generic. It simply means that after the handoff from the bootloader to the kernel, the kernel was unable to locate the boot drive again. This can happen if the BIOS successfully boots from the USB device (or even CD/HDD) and then the necessary drivers are not loaded to access the device again once the kernel takes over from the BIOS.

You should be able to find some other tickets that are USB2 specific to add your notes to, but the USB3 issue is known due to lacking XHCI in the kernel, and isn't so much a bug as a missing driver (enhancement). There's already a USB3 enhancement ticket that this is basically a duplicate of, and I think we should probably just close this ticket.

comment:13 by umccullough, 5 years ago

Resolution: duplicate
Status: newclosed

comment:14 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1

comment:15 by waddlesplash, 16 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.