Opened 5 years ago

Last modified 13 months ago

#10973 reopened bug

WebPositive ignores Proxy settings

Reported by: egrath Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: proxy, webpositive Cc:
Blocked By: Blocking: #11413, #11910, #13392
Has a Patch: no Platform: All

Description

WebPositive ignores the Proxy settings completly.

Steps to reproduce:

  1. Set up a proxy server somewhere
  2. Configure W+ to use this proxy

If you use tcpdump to monitor the outgoing packets there's no indication that W+ is using the proxy, instead direct connections to the host given by the URL are made. It even doesn't matter if you set the environment variables http_proxy and https_proxy and start W+ within this context.

I'm using hrev47380.

Change History (17)

comment:1 by egrath, 5 years ago

Component: - GeneralApplications/WebPositive
Owner: changed from nobody to pulkomandy

comment:2 by pulkomandy, 5 years ago

Milestone: R1R1/alpha5

comment:3 by pulkomandy, 5 years ago

The next version of WebKit will support proxies again. I went with the most basic HTTP or HTTPS solution, no SOCKS for now. Also the proxy authentication (username and password) aren't supported. Does anyone need these?

comment:4 by waddlesplash, 5 years ago

Resolution: fixed
Status: newclosed

No response, and the "next version" of WebKit was deployed in hrev47920. Closing as fixed.

comment:5 by pulkomandy, 5 years ago

Resolution: fixed
Status: closedreopened

Wait, what? Half the feature is still missing. You can't proxy to HTTPS right now (this needs either a "bypass proxy" mode or SOCKS support).

I can close my tickets myself when I'm done, thanks.

comment:6 by pulkomandy, 5 years ago

Blocking: 11413 added

comment:7 by Giova84, 5 years ago

As described in #11413 (sorry for the dup), I'm currently using an HTTP proxy in WebPositive (on hrev48215), but differently from this ticket, at least for me, WebPositive doesn't ignore the proxy every time: sometimes WebPositive is able to accept the proxy's directives, and the most of the time acts like if no proxy were used.

comment:8 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1

comment:9 by pulkomandy, 5 years ago

Blocking: 11910 added

comment:10 by dac324, 5 years ago

May sound like a stupid question: How can I watch this ticket?

comment:11 by pulkomandy, 5 years ago

You just subscribed by commenting on it, you should get mail notifications now.

comment:12 by pulkomandy, 4 years ago

HTTPS proxy support (through CONNECT) implemented in hrev49808 but untested. Please test and report.

comment:14 by simonsouth, 4 years ago

This appears to still be an issue in Haiku hrev49940 (x86_gcc2): WebPositive seems to be ignoring the proxy settings completely.

comment:15 by diver, 2 years ago

Blocking: 13392 added

(In #13392) Dupe of #10973

comment:16 by waddlesplash, 15 months ago

HTTP proxy support works as of hrev52050. HTTPS proxying does not work, and usually results in a "Bad data" error message. Here's an example error message from the proxy server I was testing with:

2018/07/01 22:23:41 proxy-http failed to dial: dial tcp 10.0.2.2:8443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

PulkoMandy, if you have to investigate, the proxy I was testing with was https://github.com/nadoo/glider which is very simple to use. It does indeed support CONNECT: https://github.com/nadoo/glider/blob/master/proxy/http/http.go#L109

comment:17 by waddlesplash, 13 months ago

Milestone: R1/beta1Unscheduled
Note: See TracTickets for help on using tickets.