Opened 5 years ago

Closed 3 years ago

#11377 closed bug (fixed)

[kernel] PANIC: gKernelArgs.arch_args.pgtables overflow

Reported by: chaotic Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After update to hrev48116 (as discribed in http://www.haiku-os.org/guides/daily-tasks/updating-system), Haiku doesn't boot anymore. the following message is displayed on the screen:

* PANIC * gKernelArgs.arch_args.pgtables overflow Press key to reboot.

Regards, chaotic

Change History (14)

comment:1 by diver, 5 years ago

Component: - GeneralSystem/Kernel
Owner: changed from nobody to bonefish
Status: newassigned
Summary: "PANIC" after update to hrev48116[kernel] PANIC: gKernelArgs.arch_args.pgtables overflow

comment:2 by bob_ok, 5 years ago

I have the same kernel panic problem in VirtualBox (2048Mb RAM, 1 CPU, VT-x/AMD-V, Nested Paging, PAE/NX enabled)

comment:3 by bonefish, 5 years ago

Resolution: fixed
Status: assignedclosed

I've increased the limit in hrev48117 (might need to be increased some more). Note, that new panic just highlights a pre-existing issue. But previously part of the kernel args structure would be corrupted silently. So this might actually fix other problems. Possibly even one of our favorites #8345.

comment:4 by fredruj, 4 years ago

Resolution: fixed
Status: closedreopened

I have today tried to boot Haiku, standard gcc2 version, gcc4 hyrbrid and 64-bit version on a ASUS305XU laptop. On all three versions of Haiku, I get the same error message. * PANIC * gKernelArgs.arch_args.pgables overflow Pre a key to reboot

comment:5 by anevilyak, 4 years ago

It would be helpful if you would indicate what revision you tried with.

comment:6 by fredruj, 4 years ago

I have tried with 48981.. latest of today... But I also tried 1 week ago with the latest at that point. @Diver at IRC has now built a new version of Haiku for me, with increased limit. I'll get back with the result.

comment:7 by fredruj, 4 years ago

@diver (in the IRC channel) changed the limit mentioned in this ticket, and rebuilt haiku. That actually got this problem to disappear (even though I right away stumbled into new ones).

comment:8 by korli, 4 years ago

@diver what's the status on the rebuild with a new limit?

comment:9 by diver, 4 years ago

iMe: @Diver: Hi, just wanted to inform that the increase of the limit you did yesterday actually worked. It booted up a bit longer, but then stuck again :( But the fix you did, we should try to get in to the source of Haiku. Diver: iMe: did it KDL again? iMe: @Diver: I ended up in kernel debugger land, with the error "No boot partitions found", which is strange, since I tested your ISO in a virtual machine, and it worked very nice there.

comment:10 by kallisti5, 3 years ago

Seeing this error on Intel SkyLake laptop with an i5 processor and 8GiB ram. hrev50237 x86_64

comment:11 by kallisti5, 3 years ago

I raised this again in hrev50244 (to 16) to solve the issue on SkyLake. Now seeing same "no boot partitions" from USB. (however syslog shows it does identify the AHCI drives)

comment:12 by kallisti5, 3 years ago

If anyone is interested, this is the range that pushed it over the current MAX (by 1)

"map_page: failed to allocate page table for virtual address 0x82c00000"

comment:13 by korli, 3 years ago

Can maybe this bug been closed (again)? "no boot partitions" is a different issue.

comment:14 by pulkomandy, 3 years ago

Resolution: fixed
Status: reopenedclosed

Yes, let's close this until there is a chipset that needs 17 or more.

Note: See TracTickets for help on using tickets.