Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11378 closed bug (fixed)

Webpositive: Could not open (missing symbol)

Reported by: vidrep Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking: #11381
Has a Patch: no Platform: All

Description

hrev48119 x86_gcc2 Try to open Webpositive brings up error message (see attached screenshot1).

Attachments (2)

screenshot1.png (125.3 KB ) - added by vidrep 5 years ago.
screenshot14.png (474.3 KB ) - added by kim1963 5 years ago.
hrev48118 bug

Download all attachments as: .zip

Change History (16)

by vidrep, 5 years ago

Attachment: screenshot1.png added

comment:1 by anevilyak, 5 years ago

Most likely the WebKit package needs to be rebuilt due to the changes in hrev48118.

comment:2 by ttcoder, 5 years ago

Cc: degea@… added

comment:3 by ttcoder, 5 years ago

Something interesting: if you double-click a bookmark in that situation ( haiku install upgraded to 48118), instead of getting an error like "cannot launch webpositive" you get a terminal window launching a script.. Typing ps in another Terminal I see that the window is executing Terminal /bin/sh -c /bin/wget http:..etc. Maybe it's a left-over somewhere in the Haiku folders, of the old "instaloptionalpackage" era ? Anyway it does no harm to keep that oldie in there I guess.

by kim1963, 5 years ago

Attachment: screenshot14.png added

hrev48118 bug

comment:4 by anevilyak, 5 years ago

x86_gcc2 fixed in hrev48131. x86 and x86_64 will be forthcoming as those builds complete.

comment:5 by anevilyak, 5 years ago

Owner: changed from pulkomandy to anevilyak
Status: newin-progress

comment:6 by anevilyak, 5 years ago

x86 has been updated from 1.4.5 to 1.4.6 in hrev48132.

comment:7 by vidrep, 5 years ago

Source activity erroneously says "x86: update Haikuwebkit to 1.6.3" instead of 1.4.6-3.

comment:8 by anevilyak, 5 years ago

That was a commit message typo on my part. Harmless in any case.

comment:9 by vidrep, 5 years ago

I know. Is there another communication channel for these type of things, so they don't add clutter in the ticket?

comment:10 by anevilyak, 5 years ago

Source activity feeds directly off commit messages. Once those are pushed into the repository, they're effectively set in stone, ergo there's no point in reporting them as they can't be changed anyhow.

comment:11 by vidrep, 5 years ago

Good to know. At any rate, the problem discussed in this ticket appears to have been resolved with hrev48132 and can probably be closed.

comment:12 by anevilyak, 5 years ago

There's still x86_64 to update (it's still on 1.4.5). Once that one's complete I'll close the ticket. Unfortunately, that'll still be a while, Webkit takes around an hour to build even on an i7 with SSD, so updating it on all architectures is...not the fastest of processes. Thanks for confirming on the other arch in any case though.

comment:13 by anevilyak, 5 years ago

Resolution: fixed
Status: in-progressclosed

x86_64 updated in hrev48134.

comment:14 by anevilyak, 5 years ago

Blocking: 11381 added

(In #11381) Duplicate of #11378.

Note: See TracTickets for help on using tickets.