Opened 6 years ago

Closed 2 years ago

Last modified 18 months ago

#12544 closed bug (invalid)

Shortcuts broken

Reported by: michel Owned by: nobody
Priority: normal Milestone:
Component: Preferences/Shortcuts Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

The keuboard shortcuts set in the Shortcuts preference seem to be broken in hrev49939. A existing shortcut using right-ALT-/ does not work. I created another shortcut to bring up a terminal, and it did not work either.

Change History (4)

comment:1 by diver, 6 years ago

Component: PreferencesPreferences/Shortcuts

What's your system locale? Maybe it's the same as #7505?

in reply to:  1 comment:2 by michel, 6 years ago

Replying to diver:

What's your system locale? Maybe it's the same as #7505?

English, but yes, I imagine there is a link somewhere. I tried out my other installation once it was updated to the same hrev. Same locale, one works the other doesn't.

comment:3 by leavengood, 2 years ago

Resolution: invalid
Status: newclosed

michel, if you are still around, I have done some testing and for my machine the problem with Left-Alt was that I was using the US-International keymap (which I think is the Haiku default), and in that keymap left alt is shown as Opt, and therefore it won't trigger a Left-Alt shortcut. In addition even if I configured the shortcut to use Left-Option it still did not work for that keymap. Switching to the US keymap made Left-Alt work as intended for the shortcut.

So I do not think this is a Shortcuts bug. Though Shortcuts definitely needs work either way.

comment:4 by nielx, 18 months ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.