Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#573 closed bug (fixed)

[Media] crash in BMenuBar

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by marcusoverhagen)

Start Media pref -> Audio Settings -> Channel, press None and then Audio Mixer in the left listview. Tested with 17364 in vmware.

On a side note if you click Channel label and then move your mouse over None menuitem it will change it's state to clicked, it works different in BeOS.

Attachments (1)

screen2.png (116.2 KB) - added by diver 13 years ago.
Meida pref before crash

Download all attachments as: .zip

Change History (16)

comment:1 Changed 13 years ago by axeld

I can't reproduce this (hrev17579). Can you still do this? And if so, can you provide more info?

comment:2 Changed 13 years ago by diver

Yes, i could still easely crash Media in hrev17592. Check that None menu must be pressed while you click on Audio Mixer item.

comment:3 Changed 13 years ago by axeld

I still can't reproduce this (hrev17813). Could you please check again?

comment:4 Changed 13 years ago by diver

It still valid in hrev17828. I try to prepare step by step screenshots of how to crash it, if you wont find how to do it first :-)

Changed 13 years ago by diver

Attachment: screen2.png added

Meida pref before crash

comment:5 Changed 13 years ago by jackburton

Owner: changed from axeld to jackburton

comment:6 Changed 13 years ago by jackburton

Oh, yes, now I could reproduce it.

comment:7 Changed 13 years ago by jackburton

Status: newassigned

comment:8 Changed 13 years ago by marcusoverhagen

Cc: marcusoverhagen added
Description: modified (diff)
Platform: All

comment:9 Changed 12 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Fixed in hrev20799.

comment:10 Changed 12 years ago by diver

Resolution: fixed
Status: closedreopened

I can still reproduce it with hrev22554, reopening.

comment:11 Changed 12 years ago by jackburton

It was fixed in hrev20799, but the change in hrev21961 made it show up again. And, although the symptoms are different, it has the same cause as bug #582.

comment:12 Changed 12 years ago by korli

Stefano, could you have a look at a change I made in hrev22559 ? It fixed the menu issue I had, dunno if this is correct though.

comment:13 in reply to:  12 Changed 12 years ago by jackburton

Replying to korli:

Stefano, could you have a look at a change I made in hrev22559 ? It fixed the menu issue I had, dunno if this is correct though.

That change looks okay. It's always good to keep on the defensive, at least. So this bug is fixed ?

comment:14 Changed 12 years ago by korli

Resolution: fixed
Status: reopenedclosed

It seems fixed to me. Let's see if it is for diver :)

comment:15 Changed 12 years ago by pieterpan

Is fixed for me (I reported it in #1417) Well done!

Note: See TracTickets for help on using tickets.