Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#573 closed bug (fixed)

[Media] crash in BMenuBar

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by marcusoverhagen)

Start Media pref -> Audio Settings -> Channel, press None and then Audio Mixer in the left listview. Tested with 17364 in vmware.

On a side note if you click Channel label and then move your mouse over None menuitem it will change it's state to clicked, it works different in BeOS.

Attachments (1)

screen2.png (116.2 KB ) - added by diver 13 years ago.
Meida pref before crash

Download all attachments as: .zip

Change History (16)

comment:1 by axeld, 14 years ago

I can't reproduce this (hrev17579). Can you still do this? And if so, can you provide more info?

comment:2 by diver, 14 years ago

Yes, i could still easely crash Media in hrev17592. Check that None menu must be pressed while you click on Audio Mixer item.

comment:3 by axeld, 14 years ago

I still can't reproduce this (hrev17813). Could you please check again?

comment:4 by diver, 14 years ago

It still valid in hrev17828. I try to prepare step by step screenshots of how to crash it, if you wont find how to do it first :-)

by diver, 13 years ago

Attachment: screen2.png added

Meida pref before crash

comment:5 by jackburton, 13 years ago

Owner: changed from axeld to jackburton

comment:6 by jackburton, 13 years ago

Oh, yes, now I could reproduce it.

comment:7 by jackburton, 13 years ago

Status: newassigned

comment:8 by marcusoverhagen, 13 years ago

Cc: marcusoverhagen added
Description: modified (diff)
Platform: All

comment:9 by jackburton, 13 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev20799.

comment:10 by diver, 12 years ago

Resolution: fixed
Status: closedreopened

I can still reproduce it with hrev22554, reopening.

comment:11 by jackburton, 12 years ago

It was fixed in hrev20799, but the change in hrev21961 made it show up again. And, although the symptoms are different, it has the same cause as bug #582.

comment:12 by korli, 12 years ago

Stefano, could you have a look at a change I made in hrev22559 ? It fixed the menu issue I had, dunno if this is correct though.

in reply to:  12 comment:13 by jackburton, 12 years ago

Replying to korli:

Stefano, could you have a look at a change I made in hrev22559 ? It fixed the menu issue I had, dunno if this is correct though.

That change looks okay. It's always good to keep on the defensive, at least. So this bug is fixed ?

comment:14 by korli, 12 years ago

Resolution: fixed
Status: reopenedclosed

It seems fixed to me. Let's see if it is for diver :)

comment:15 by pieterpan, 12 years ago

Is fixed for me (I reported it in #1417) Well done!

Note: See TracTickets for help on using tickets.