Opened 12 years ago

Closed 11 years ago

#2326 closed bug (fixed)

KDL: remove page 0x91d46aa0 from cache 0x91365060: page still has mappings!

Reported by: kaliber Owned by: bonefish
Priority: blocker Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: scottmc
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I was using hrev25653 for two weeks and it was very stable. Now I'm using hrev25759 and it drops into KDL in about 5-10 minutes.

e.g.

PANIC: remove page 0x91d46aa0 from cache 0x91365060: page still has mappings!

Welcome to Kernel Debugging Land...
Running on CPU 0
kdebug> bt
stack trace for thread 520 "sh"
    kernel stack: 0x92100000 to 0x92104000
      user stack: 0x7efe7000 to 0x7ffe7000
frame            caller     <image>:function + offset
92103a9c (+  48) 8004b8d5   <kernel>:invoke_debugger_command + 0x00ed
92103acc (+  64) 8004b6cd   <kernel>:invoke_pipe_segment__FP21debugger_command_pipelPc + 0x0079
92103b0c (+  64) 8004ba15   <kernel>:invoke_debugger_command_pipe + 0x009d
92103b4c (+  48) 8004c8f0   <kernel>:_ParseCommandPipe__16ExpressionParserRi + 0x0234
92103b7c (+  48) 8004c2a6   <kernel>:EvaluateCommand__16ExpressionParserPCcRi + 0x01de
92103bac (+ 224) 8004dcbc   <kernel>:evaluate_debug_command + 0x0088
92103c8c (+  64) 80049f96   <kernel>:kernel_debugger_loop__Fv + 0x017a
92103ccc (+  48) 8004a917   <kernel>:kernel_debugger + 0x0117
92103cfc (+ 192) 8004a7f5   <kernel>:panic + 0x0029
92103dbc (+  48) 80099514   <kernel>:delete_cache__FP8vm_cache + 0x0080
92103dec (+  48) 80099a25   <kernel>:vm_cache_release_ref + 0x003d
92103e1c (+ 256) 800973b3   <kernel>:vm_soft_fault__FUlbT1 + 0x0e37
92103f1c (+  64) 8009631a   <kernel>:vm_page_fault + 0x002e
92103f5c (+  64) 800a08ad   <kernel>:page_fault_exception + 0x00b1
92103f9c (+  12) 800a3fd3   <kernel>:int_bottom_user + 0x005a (nearest)
iframe at 0x92103fa8 (end = 0x92104000)
 eax 0x1800c3d0     ebx 0x340e08        ecx 0x1          edx 0x180039d4
 esi 0x7ffe651c     edi 0x79            ebp 0x7ffe64d0   esp 0x92103fdc
 eip 0x2c6a0d    eflags 0x10212    user esp 0x7ffe6498
 vector: 0xe, error code: 0x4
92103fa8 (+   0) 002c6a0d   10879:libroot.so_seg0ro@0x00295000 + 0x31a0d
7ffe64d0 (+  80) 002c7816   10879:libroot.so_seg0ro@0x00295000 + 0x32816
7ffe6520 (+  48) 002c8f4d   10879:libroot.so_seg0ro@0x00295000 + 0x33f4d
7ffe6550 (+  48) 0022a376   10876:sh_seg0ro@0x00200000 + 0x2a376
7ffe6580 (+  48) 0022a46b   10876:sh_seg0ro@0x00200000 + 0x2a46b
7ffe65b0 (+  48) 0022694c   10876:sh_seg0ro@0x00200000 + 0x2694c
7ffe65e0 (+ 112) 00226ca6   10876:sh_seg0ro@0x00200000 + 0x26ca6
7ffe6650 (+  96) 00224236   10876:sh_seg0ro@0x00200000 + 0x24236
7ffe66b0 (+  96) 002251aa   10876:sh_seg0ro@0x00200000 + 0x251aa
7ffe6710 (+  64) 00225384   10876:sh_seg0ro@0x00200000 + 0x25384
7ffe6750 (+  96) 002244b8   10876:sh_seg0ro@0x00200000 + 0x244b8
7ffe67b0 (+  80) 002679ca   10876:sh_seg0ro@0x00200000 + 0x679ca
7ffe6800 (+  76) 00233b18   10876:sh_seg0ro@0x00200000 + 0x33b18
7ffe684c (+ 112) 0023689b   10876:sh_seg0ro@0x00200000 + 0x3689b
7ffe68bc (+  64) 00231e4d   10876:sh_seg0ro@0x00200000 + 0x31e4d
7ffe68fc (+  96) 00231f1b   10876:sh_seg0ro@0x00200000 + 0x31f1b
7ffe695c (+  48) 002320f6   10876:sh_seg0ro@0x00200000 + 0x320f6
7ffe698c (+  48) 002321a0   10876:sh_seg0ro@0x00200000 + 0x321a0
7ffe69bc (+  64) 002454d5   10876:sh_seg0ro@0x00200000 + 0x454d5
7ffe69fc (+  64) 002456c3   10876:sh_seg0ro@0x00200000 + 0x456c3
7ffe6a3c (+  80) 00245ef6   10876:sh_seg0ro@0x00200000 + 0x45ef6
7ffe6a8c (+  48) 00245282   10876:sh_seg0ro@0x00200000 + 0x45282
7ffe6abc (+  48) 00227cc2   10876:sh_seg0ro@0x00200000 + 0x27cc2

Change History (10)

comment:1 by nielx, 12 years ago

Summary: Haiku is very unstable since about two weeksKDL: remove page 0x91d46aa0 from cache 0x91365060: page still has mappings!

To reproduce:

  1. wget pkg-config (http://pkgconfig.freedesktop.org/releases/pkg-config-0.23.tar.gz)
  2. configure. After the check whether it should build shared libraries, you will get this error message. 'continue' in KDL will move the process forward until there is a point in configuring the subtarget glib where the configure process hangs.

comment:2 by nielx, 12 years ago

See #2338 for a complete syslog and serial log.

comment:3 by scottmc, 12 years ago

Cc: scottmc added

Sorry for dupe, I will follow this one. I'll try an older version until this gets resolved as it stops most porting work until it's fixed.

comment:4 by axeld, 12 years ago

Milestone: R1R1/alpha1
Priority: normalblocker

comment:5 by mmlr, 12 years ago

Not that I'd have the slightest idea of the exact reason, but I guess hrev25716/hrev25717 are to blame for this one.

comment:6 by axeld, 12 years ago

Owner: changed from axeld to bonefish

You guess because it used to work before? In any case, it cannot hurt to let Ingo have a go at it (I won't have much time for the next week) :-)

comment:7 by scottmc, 12 years ago

I can confirm that it happened sometime AFTER hrev25657, which is what I have moved back to until this gets fixed. In hrev25657 building packages seems to be stable. I do have some other dev images I can go back to and check, (hrev25673, rr25717, hrev25721) if that would be helpful in pinpointing when this problem started. Just let me know.

comment:8 by kaliber, 11 years ago

I reverted hrev25716 and hrev25717 and now it seems to be stable again.

comment:9 by bonefish, 11 years ago

Status: newassigned

Looking into it.

comment:10 by bonefish, 11 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev26068.

Note: See TracTickets for help on using tickets.