Opened 11 years ago

Closed 11 years ago

#2351 closed bug (fixed)

Tracker crashing: va 0x14 not covered by area in address space

Reported by: luroh Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

SW: 32-bit Ubuntu 8.04, Vmware Player 2.0.3, vmware and hdd image built with gcc 4.1.2, hrev25852 HW: 1) Lenovo T60 laptop 2) Home built AMD64 desktop system 3) 1GB USB 2.0 stick

Ever since I switched to building with gcc4 a couple of days ago, I see Tracker crashing on shutdown/reboot. The behaviour is the same in vmware as well as when booting off a USB stick. Thinking it might have had something to do with multi-core CPUs, I tried building on my single-core AMD64 machine but the result was the same. The problem does not appear with the official Build Factory images.

Never-booted vmware image available at http://www.megaupload.com/?d=6KUY6OL6

Attachments (3)

gdb1.png (104.6 KB) - added by luroh 11 years ago.
gdb2.png (94.5 KB) - added by luroh 11 years ago.
haiku-serial-port.txt (30.0 KB) - added by luroh 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by luroh

Attachment: gdb1.png added

Changed 11 years ago by luroh

Attachment: gdb2.png added

Changed 11 years ago by luroh

Attachment: haiku-serial-port.txt added

comment:1 Changed 11 years ago by umccullough

I can confirm seeing this also when doing a gcc4 build on my laptop while a gcc2 build on the same machine works fine.

Since I rarely use gcc4 yet, I haven't had time to provide the necessary debug info but can also do so if it will help debug this further.

comment:2 Changed 11 years ago by julun

Resolution: fixed
Status: newclosed

I'm going to close this one, it seems to be fixed with hrev26383.
I tested with and without the patch on gcc 4 and the crash does not show up if the patch is applied.

Note: See TracTickets for help on using tickets.