Opened 11 years ago

Closed 5 years ago

Last modified 10 months ago

#2479 closed bug (no change required)

System reboots before reaching splash screen

Reported by: lawsonwa Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #6811
Has a Patch: no Platform: All

Description

Expected behavior: The sytem boots to the Haiku desktop.

Experienced behavior: The system will reboot before reaching the haiku splash screen.

Steps to reproduce: Attempt to book Haiku from disk.

Motherboard - Gigabyte P35-DSR3 (rev 2.0)

Processor - Intel Core2 Duo E6550.

Boot Volume - SATA hard disk (/dev/sda4 in Linux)

Attachments (1)

rev26236.log (5.6 KB) - added by lawsonwa 11 years ago.
Boot log from the serial port

Download all attachments as: .zip

Change History (25)

Changed 11 years ago by lawsonwa

Attachment: rev26236.log added

Boot log from the serial port

comment:1 Changed 11 years ago by stippi

If you build your own images, you could try to switch to the new ATA bus manager. Change the file src/add-ons/kernel/bus_managers/Jamfile, the line

SubInclude HAIKU_TOP src add-ons kernel bus_managers ide ;

->

SubInclude HAIKU_TOP src add-ons kernel bus_managers ata ;

Does that change anything?

comment:2 Changed 11 years ago by lawsonwa

Using the ATA bus manager gives the same results.

comment:3 Changed 11 years ago by mmlr

It looks like this happens in the bootloader already so the ide/ata bus managers aren't yet used. I had "similar" issues when doing the kernel heap rewrite yesterday. I had uninitialized memory in there that would lead to a triple fault and therefore a reboot. It didn't show up in QEMU as it entirely depends on what happens to be in the RAM pages at the time (under QEMU it was all 0 so didn't cause problems). So maybe there are some uninitialized variables/structures/pointers used in the bootloader that usually happen to be 0, but on this specific system/configuration aren't? Of course this is just a wild guess because the outcome is the same, there are of course many other possible reasons for this.

comment:4 Changed 11 years ago by lawsonwa

I tried again at rev 26283 and the system now boots as expected.

comment:5 in reply to:  4 Changed 10 years ago by mikesum32

Seem to have regressed, at least when I tried booting with a Gigabyte GA-EP35-DS3R via USB and DVD image. It will reboot before reaching the haiku splash screen.

comment:6 Changed 10 years ago by jontew

I have the same problem, and I have actually tried hunting down the bug in the bootloader. Since I have no serial debugging I had to debug it with printfs and loops, but now I know what causes the reboot. I tracked the bug down in the code the following way: (root directory: /trunk/src/system/boot/)

loader/main.cpp: get_boot_filesystem ->

platform/bios_ia32/devices.cpp: platform_add_boot_device ->

platform/bios_ia32/devices.cpp: BIOSDrive (Constructor) ->

platform/bios_ia32/devices.cpp: are_extensions_avaiblable

In the function are_extensions_avaiblable(uint8 drive); there is a call to the bios for interrupt 0x13, when that is executed the computer reboots instantly. I have tried to execute interrupt 0x10 before this just to see if other interrupts are working and it did.

And to further see if there is some bug with my BIOS I wrote my own little bootsector that only tests interrupt 0x13 in real mode and it works without rebooting, so my theory now is that there has to be something with the switching between protected mode -> real mode -> protected mode in bios.S but I haven't had time to check this out yet.

My setup is:

Motherboard: Gigabyte EX38-DS4 (Intel X38 chipset) CPU: Core 2 Duo E8400 RAM: 4096 MB Kingston Graphics: 2x ATI Radeon HD4850 (CrossFire) Boot device: 16Gb Kingston USB flash drive.

comment:7 Changed 8 years ago by scottmc

@ lawsonwa, mikesum32, and jontew, have you tried newer Haiku builds on the same hardware that was failing when you first reported your issues here? If so, which Haiku rxxxxx, and did it work any better?

comment:8 Changed 8 years ago by umccullough

The original issue reported in this ticket is resolved (see comment:4 "I tried again at rev 26283 and the system now boots as expected.")

I believe that the other issues reported in this ticket should be opened as separate tickets if they still occur. It's possible that the issues are resolved anyway.

comment:9 Changed 8 years ago by lawsonwa

I tried again this morning with rev 40074 on a thumb drive and the reboot problem seems to be back. The same thumb drive boots fine on other machines. If I get time, I will try a hard drive install to see if that also has the problem. If I get even more time than that, I'll see if I can narrow down when the problem came back.

Last edited 8 years ago by lawsonwa (previous) (diff)

comment:10 in reply to:  9 ; Changed 8 years ago by umccullough

Replying to lawsonwa:

I tried again this morning with rev 40074 on a thumb drive and the reboot problem seems to be back.

Was that using the Anyboot image? I ask because some BIOS don't like booting USB sticks using the RAW image due to the missing MBR (I have encountered several machines that do this).

Booting from a partition on the HD would be a better test to conclude this particular ticket I think.

comment:11 in reply to:  10 Changed 8 years ago by lawsonwa

Replying to umccullough:

Was that using the Anyboot image?

Yes, it was an Anyboot image. I will try this from a hard drive partition just as soon as I get some time.

comment:12 Changed 8 years ago by lawsonwa

Rev 40074 boots correctly when installed to a hard disk. Please let me know if there is any other testing you want me to do.

comment:13 Changed 8 years ago by starsseed

...

Last edited 8 years ago by starsseed (previous) (diff)

comment:14 Changed 8 years ago by starsseed

Blocking: 6811 added

(In #6811) a possible duplicate of #2479

comment:15 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:16 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:17 in reply to:  15 Changed 8 years ago by lawsonwa

Replying to scottmc:

Can you recheck this with a recent Haiku build?


I just tried hrev42061:
Booting from a hard disk (dd the raw image to a partition) works.
Booting from a USB stick (dd the anyboot image to the device) reboots before the splash screen.
Booting from a CD (burned the iso with Nero) works.

Note that the USB stick boots just fine on a couple of other machines, but the Gigabyte motherboard (mentioned in the original report) doesn't like it.

Please let me know if there's anything else you'd like me to try.

comment:18 Changed 8 years ago by umccullough

Perhaps worth testing with the MBR patch by starsseed in #3441 to see if that resolves it.

comment:19 Changed 8 years ago by jackburton

Worth testing with hrev42068.

comment:20 Changed 5 years ago by pulkomandy

Hi, Is this still a problem with current nightlies?

comment:21 in reply to:  20 Changed 5 years ago by lawsonwa

Replying to pulkomandy:

Is this still a problem with current nightlies?

Unfortunately the only piece of hardware which exhibits this problem is no longer functional, so I will not be able to re-test.

comment:22 Changed 5 years ago by vidrep

This may be related to ticket #10558, where the PC goes into a continuous reboot loop only with Haiku.

comment:23 Changed 5 years ago by pulkomandy

Resolution: no change required
Status: newclosed

Well, with no hardware to test and not much hints as to what the problem could be, I'm going to close this ticket for now. If someone has a similar problem, please open a new ticket and put a link to this one if you think it is similar.

There are other known issues with interrupt 13 (disk access) not working properly:

  • #11019 - reboot on attempt to read a sector from SATA-PCI card
  • LBA access on Apple machines doesn't work in stage2 bootloader

comment:24 Changed 10 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.