Opened 11 years ago

Closed 10 years ago

#2491 closed bug (fixed)

Haiku Live CD reboots right away

Reported by: emitrax Owned by: axeld
Priority: high Milestone: R1
Component: System Version: R1/pre-alpha1
Keywords: Cc: adek336@…, mattmadia@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I created a boot cd with the following

jam -q haiku-boot-cd
jam -q haiku-image
cdrecord dev=/dev/hda -v -eject -dao -data generated/haiku-boot-cd.iso generated/haiku.image

but when I boot from the cd the system reboots right away.

Here is a the output of lspci from linux

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
05:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)
05:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
05:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
05:09.2 System peripheral: Ricoh Co Ltd Device 0843 (rev 01)
05:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
05:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

Any idea?

Change History (12)

comment:1 by Adek336, 11 years ago

Cc: adek336@… added

comment:2 by Adek336, 11 years ago

I can confirm this in hrev28965 both on real hardware and QEMU. Image built with jam -q haiku-image + jam -q haiku-boot-cd.

More testing on QEMU: the only serial message before the triple fault happens is

APM version %d available, flags %ad_allocsmp: using ACPI to detect MP configuration

EIP=0002c877

Pressing space does not open the boot options (reboots)

boot cd made from hrev24300 does not restart itself (although #347 happens)

comment:3 by Adek336, 11 years ago

The first faulty revision is hrev24434.

comment:4 by stippi, 11 years ago

Maybe it's the blit16_cropped() call? What happens if you comment that out? It looks a bit strange, maybe I am missing a bit of context, but if the boot screen is 8bpp, it looks like it would not handle that and then blit outside the video memory.

comment:5 by Adek336, 11 years ago

wow, you're good! indeed it fixes it for hrev24434. but the code has evolved since then so it's not quite it for hrev28965.

comment:6 by stippi, 11 years ago

Ok, I can have a look later. It's suspicious that this should only be a problem for CD booting. It should be a problem on regular harddisks as well.

comment:7 by Adek336, 11 years ago

I've rechecked out and I can't reproduce it (tested on QEMU). Probably stall object files!

comment:8 by mmadia, 11 years ago

Cc: mattmadia@… added

With mmu_man's recent LiveCD work, can you test this again emitrax ?

in reply to:  8 comment:9 by emitrax, 11 years ago

Replying to mmadia:

With mmu_man's recent LiveCD work, can you test this again emitrax ?

Same behavior. It reboots right away. If I don't mistake, I saw some "dots" right before rebooting. Don't know if that helps.

comment:10 by leszek, 10 years ago

Same problem here.

But this also happens with any image not only the iso one.

So a dd'ed raw image has the same behavior on my system.

Some old 23XXXX revisions worked and work well on that machine. Its an A7n8x-x Asus Board with an AMD2600+ and 1200 MB RAM. I tried enabling and disabling APIC in the BIOS, that didn't changed anything.

comment:11 by scottmc, 10 years ago

Can you retry this using an Anyboot image?

comment:12 by emitrax, 10 years ago

Resolution: fixed
Status: newclosed

Tried with hrev36878.

The system no longer reboots.

It hangs after the rocket icon light up. I'll track it with another bug. Closing this one.

Note: See TracTickets for help on using tickets.