Opened 11 years ago

Closed 10 years ago

#2845 closed bug (fixed)

[kernel] vm_page_fault: block notifier/writer

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: mdisreali@…
Blocked By: Blocking: #4449
Has a Patch: no Platform: All

Description

Since some revisions (2-3 days) Haiku running in VirtualBox start to drop to KDL after several minutes.

Attachments (11)

kdl-bt.png (251.3 KB) - added by diver 11 years ago.
kdl_new.png (67.1 KB) - added by diver 11 years ago.
kdl.png (47.6 KB) - added by diver 11 years ago.
notifier.png (75.3 KB) - added by diver 11 years ago.
notifier2.png (41.7 KB) - added by diver 11 years ago.
img_1650.jpg (216.0 KB) - added by Adek336 11 years ago.
img_1652.jpg (244.7 KB) - added by Adek336 11 years ago.
img_1654.jpg (135.6 KB) - added by Adek336 11 years ago.
img_1656.jpg (54.2 KB) - added by Adek336 11 years ago.
img_1703.jpg (162.0 KB) - added by Adek336 11 years ago.
r32402_bezilla_kdl.jpg (277.0 KB) - added by Disreali 10 years ago.

Download all attachments as: .zip

Change History (37)

comment:1 Changed 11 years ago by diver

It seems that I can't add attachments to Trac. Oh well..

comment:2 Changed 11 years ago by axeld

Please save it until that annoying Trac problem is resolved, thanks!

Changed 11 years ago by diver

Attachment: kdl-bt.png added

comment:3 Changed 11 years ago by diver

With recent revision back trace became much shorter:

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x1, ip 0x800033c90

Welcome to Kernel Debugging Land...
Thread 143 "w>Deskbar "
kernel stack : 0x90b73000 to 0x90b77000[[BR]]user stack : 0x700c3000 to 0x70103000
frame caller <image>:function + offset

[*** READ FAULT at 0x80059b19, pc: 0x80035200 ***]

comment:4 Changed 11 years ago by axeld

At least the stack crawl should now look better again. Apart from that, it seems like the crawl of the last comment doesn't have much in common with the previous one.

I'm using VirtualBox myself on my laptop, and never saw anything like this either (also I used version 2.0.2 until today). Is there anything special you are doing to reproduce this problem?

comment:5 in reply to:  4 Changed 11 years ago by diver

Replying to axeld:

Is there anything special you are doing to reproduce this problem?

Nope, it just hanged when I leaved it running for some time (about 10 min.) Also with recent revision it survived about an hour until i shutdown VirtualBox myself. So it could be fixed already, I will retest and post back my results.

comment:6 Changed 11 years ago by diver

Ok, I left Haiku running in VirtualBox 2.0.2 today morning and now, 7 hours later, it still running. So I think we could close this bug, I'll reopen it if I have this crash again.

comment:7 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Okay, thanks for the update.

Changed 11 years ago by diver

Attachment: kdl_new.png added

comment:8 Changed 11 years ago by diver

Happens to me again in hrev28510.

comment:9 Changed 11 years ago by axeld

This problem could have been caused by a bug I fixed in hrev28516 - please retry with a version later than that one.

comment:10 Changed 11 years ago by diver

Resolution: fixed
Status: closedreopened

Another crash in 28524.

comment:11 Changed 11 years ago by axeld

With what stack trace, please?

comment:12 Changed 11 years ago by diver

I'm trying to get one, but VirtualBox doesn't let me get to vm showing guru mediatation error. I'll try again.

Changed 11 years ago by diver

Attachment: kdl.png added

comment:13 Changed 11 years ago by diver

Here you are.

comment:14 Changed 11 years ago by diver

Oh now, it's not about block notifier/writer which i got earler today.

comment:15 Changed 11 years ago by axeld

Blocking: 3108 added

(In #3108) This seems to be a duplicate of #2845

comment:15 Changed 11 years ago by axeld

Blocking: 3108 removed

The stack trace you posted doesn't look good at all, and might very well be a VirtualBox problem.

The one from #3108 looks related to this problem, though. In any case, I'm not bumping this to R1/alpha unless this happens on real hardware (I've never seen this yet, and I'm using VirtualBox on my laptop as well).

comment:16 Changed 11 years ago by diver

It seems like a bug in VirtualBox, see http://www.virtualbox.org/ticket/2588

Changed 11 years ago by diver

Attachment: notifier.png added

Changed 11 years ago by diver

Attachment: notifier2.png added

Changed 11 years ago by Adek336

Attachment: img_1650.jpg added

Changed 11 years ago by Adek336

Attachment: img_1652.jpg added

Changed 11 years ago by Adek336

Attachment: img_1654.jpg added

Changed 11 years ago by Adek336

Attachment: img_1656.jpg added

comment:17 Changed 11 years ago by Adek336

hrev28884 on real hardware when using Transmission, 9 minutes uptime, syslog has "kernel thread accessing invalid user memory", I was able to suspend the thread and continue although not very well (Deskbar froze, command sync in terminal wouldn't finish, could not open new terminal tab; on the other hand, transmission was still able to download)

Changed 11 years ago by Adek336

Attachment: img_1703.jpg added

comment:18 Changed 11 years ago by Adek336

Happened two more times, perhaps induced by heavy syslog traffic.

comment:19 Changed 10 years ago by diver

I still can reproduce it in vbox 2.0.2, but not under vmware.

comment:20 Changed 10 years ago by diver

Can't reproduce it anymore in VirtualBox 3.0.4

comment:21 Changed 10 years ago by Disreali

I am experiencing this issue when testing hrev32402 with VirtualBox 3.0.4-hrev50677 on Windows Vista host. I'll get less than thirty or so minutes and it kdl's. Each time it kdl's I had been checking e-mail on yahoo, so I thought it may have been bezilla, but umccullough directed me here.

Changed 10 years ago by Disreali

Attachment: r32402_bezilla_kdl.jpg added

comment:22 Changed 10 years ago by Disreali

Cc: mdisreali@… added

No longer experiencing this issue with hrev32448. Though, from reading this ticket, the issue seems to come and go depending on the haiku revision.

comment:23 Changed 10 years ago by anevilyak

Blocking: 4449 added

comment:25 Changed 10 years ago by Disreali

I was running Haiku R1A1 hrev32991 in VirualBox 3.0.4. I had Virtualbox in the background for a minute or two and whan I went back to it, Haiku had crashed. mmlr tried to help debug.

Copied from duplicate ticket: see ticket:4449 for screenshots

comment:26 Changed 10 years ago by bonefish

Resolution: fixed
Status: reopenedclosed

There's a chance that hrev34655 fixes the problem. Closing. Please reopen if the issue persists.

Note: See TracTickets for help on using tickets.