Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#556 closed bug (fixed)

[sh] getNumAvailable() == 0

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev17256, sh crash on start with this back trace:

Thread 240 called debugger(): getNumAvailable() == 0 Reading symbols from /boot/beos/system/lib/libroot.so...done. Loaded symbols for /boot/beos/system/lib/libroot.so [Switching to team /bin/sh (240) thread sh (240)] 0x002b73bf in _kern_debugger () from /boot/beos/system/lib/libroot.so (gdb) bt #0 0x002b73bf in _kern_debugger () from /boot/beos/system/lib/libroot.so #1 0x002b278f in debugger () from /boot/beos/system/lib/libroot.so #2 0x002b9221 in assert_fail () from /boot/beos/system/lib/libroot.so #3 0x002bfc88 in BPrivate::threadHeap::malloc ()

from /boot/beos/system/lib/libroot.so

#4 0x002c05d1 in malloc () from /boot/beos/system/lib/libroot.so #5 0x0024c12d in xmalloc () #6 0x002203ea in make_bare_word () #7 0x00237a0f in expand_word_internal () #8 0x002382e8 in shell_expand_word_list () #9 0x0023853a in expand_word_list_internal () #10 0x00237e95 in expand_words () #11 0x002268d2 in execute_simple_command () #12 0x00223d87 in execute_command_internal () #13 0x00267e18 in parse_and_execute () #14 0x0021867f in execute_prompt_command () #15 0x0021f29a in parse_command () #16 0x0021f39b in read_command () #17 0x0021f0a5 in reader_loop () #18 0x0021d212 in main () (gdb)

Change History (5)

comment:1 Changed 13 years ago by diver

It seems that this bug is caused by #501

comment:2 Changed 13 years ago by diver

dependson: 501

comment:3 Changed 13 years ago by diver

Hmm, can't reproduce it anymore, probably fixed. Closing bug.

comment:4 Changed 13 years ago by diver

Resolution: fixed

comment:5 Changed 13 years ago by diver

Status: newclosed
Note: See TracTickets for help on using tickets.