Opened 10 years ago

Closed 10 years ago

#5199 closed bug (duplicate)

media_addon_server crash on reboot/shutdown

Reported by: luroh Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

rev 34865, gcc2, running on real hardware (T60 laptop)

media_addon_server reasonably reliably crashes (gdb) when rebooting or shutting down. However, pressing the 'Debug' button does not open a gdb window; I guess the shutdown procedure has gone too far already.

This laptop has working HDA sound with the native driver.

From what I can tell, the crash doesn't look too similar to #5120 or #5150.

syslog attached

Attachments (2)

syslog (91.0 KB ) - added by luroh 10 years ago.
media_server.jpg (463.8 KB ) - added by Grey 10 years ago.

Download all attachments as: .zip

Change History (6)

by luroh, 10 years ago

Attachment: syslog added

in reply to:  description comment:1 by Grey, 10 years ago

Replying to luroh:

rev 34865, gcc2, running on real hardware (T60 laptop)

media_addon_server reasonably reliably crashes (gdb) when rebooting or shutting down. However, pressing the 'Debug' button does not open a gdb window; I guess the shutdown procedure has gone too far already.

This laptop has working HDA sound with the native driver.

The same failure on my ThinkPad T400 (rev 34863, gcc4).

BTW, it's possible to press Ctrl+Alt+Del, then restart Desktop and call gdb.

syslog and gdb log attached

by Grey, 10 years ago

Attachment: media_server.jpg added

comment:2 by phoudoin, 10 years ago

I've the same issue too, under a gcc4 hybrid since the MediaKit port pool changes (~r347xx from memory). Good news is it's reproducible, as it always crash media_addon_server when PortPool::GetPort() is called.

comment:3 by bonefish, 10 years ago

Owner: changed from marcusoverhagen to axeld
Status: newassigned

Axel seems to be too lazWpreoccupied to comment on this. The issue is known to be a static uninitialization order problem and Axel promised to fix it soon. :-)

comment:4 by korli, 10 years ago

Resolution: duplicate
Status: assignedclosed

duplicate #5166

Note: See TracTickets for help on using tickets.