Opened 9 years ago

Closed 3 years ago

#5289 closed bug (fixed)

[Expander] wrong layout of controls

Reported by: diver Owned by: yourpalal
Priority: normal Milestone: R1
Component: Applications/Expander Version: R1/Development
Keywords: gci2011 Cc:
Blocked By: Blocking: #6228
Has a Patch: yes Platform: All

Description


Tested with hrev35141.

Attachments (2)

Expander.png (47.9 KB) - added by diver 9 years ago.
0001-Expander-fix-status-view.patch (6.0 KB) - added by KapiX 3 years ago.
This patch removes the workaround and fixes the issue.

Download all attachments as: .zip

Change History (30)

comment:1 Changed 9 years ago by anevilyak

Maybe I'm blind, but I don't see the difference between the two screenshots. Also this sounds like a duplicate of #5283.

comment:2 Changed 9 years ago by diver

Look at the right border.

Changed 9 years ago by diver

Attachment: Expander.png added

comment:3 Changed 9 years ago by anevilyak

Ah. Too early in the morning :)

comment:4 Changed 9 years ago by julun

Hi, I didn't see the issue in the latest build. Please add some steps on how to reproduce.

comment:5 Changed 9 years ago by diver

Try to open large archive with many files. It seems that Expander relayout itself once again after it finishes building content listing and everything looks just fine. But while it still builds that listing UI controls are out of place. So with small archive you will not see this problem.

comment:6 Changed 9 years ago by stpere

Owner: changed from korli to stpere
Status: newin-progress

comment:7 Changed 9 years ago by diver

Version: R1/alpha1R1/Development

comment:8 Changed 9 years ago by julun

Hi, is the task still valid? If I remember correctly stpere fixed it some weeks ago. Could you please verify.

comment:9 Changed 9 years ago by diver

Yes it is still valid. layout of Expander is pretty much broken now.

comment:10 Changed 9 years ago by axeld

Blocking: 6228 added

(In #6228) Please always add the duplicate info to the "Blocked By" field.

comment:11 Changed 9 years ago by diver

Still with us in hrev38300.

comment:12 Changed 9 years ago by pulkomandy

Owner: changed from stpere to yourpalal
Status: in-progressassigned

This is a layout bug, reassigning to yourpalal as he knows best :)

comment:13 Changed 9 years ago by yourpalal

Thanks pulkomandy, I'll look into this soon :)

comment:14 Changed 9 years ago by diver

Tracker settings window and ScreenShot app look odd now.

comment:15 Changed 9 years ago by diver

Also something wrong with Icon-o-Matic.

comment:16 Changed 9 years ago by diver

Ouch, sorry, wrong bug. Should have posted it in in #5614 :-\

comment:17 Changed 9 years ago by diver

Yourpalal, any news?

comment:18 in reply to:  17 Changed 9 years ago by yourpalal

Replying to diver:

Yourpalal, any news?

Not really right now.. I'm busy with school and GCI, and my current Haiku work is focusing on the Media preflet (I'm just about done with it though).

comment:19 Changed 8 years ago by yourpalal

Status: assignedin-progress

comment:20 Changed 8 years ago by yourpalal

Status: in-progressassigned

I'm taking this out of 'in-progress', since I'm not actually working on it right now. I still intend to get to it, but I don't want to stop anyone from working on it.

comment:21 Changed 8 years ago by Bth8

Doesn't seem to be valid any longer

comment:22 Changed 8 years ago by humdinger

It's still valid. It depends on how long the contained paths/filenames are. When the list is done, the window is resized to the longest line. To see the effect, you'll have to test with an archive with many, many files in it. Also, make the window quite narrow.
IMO, Expander should just keep the window width as it is before showing the contents and keep the horizontal scrollbar.

Last edited 8 years ago by humdinger (previous) (diff)

comment:23 Changed 8 years ago by Bth8

Ah, yeah, I see it now. It's present while the list is populating and while shrinking the window horizontally.

comment:24 Changed 8 years ago by umccullough

Keywords: gci2011 added

comment:25 Changed 8 years ago by ctbeiser

Still present in hrev 43475.

comment:26 Changed 7 years ago by siarzhuk

Should workaround in hrev45000 be counted as solution for this ticket?

Changed 3 years ago by KapiX

This patch removes the workaround and fixes the issue.

comment:27 Changed 3 years ago by KapiX

Has a Patch: set

comment:28 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Applied in hrev50499. Thanks!

Note: See TracTickets for help on using tickets.