Opened 13 years ago

Closed 11 years ago

#533 closed bug (fixed)

[KDL] while trying to unzip large .zip file

Reported by: diver Owned by: axeld
Priority: blocker Milestone: R1/alpha1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

I tried to unzip 300mb zip archive, i double clicked it and pressed "Show contents" in Expander window. After that it drops me to KDL with message:

PANIC: realloc(): page 0xblablabla invalid bin_index 24

Attachments (1)

Expnader (1.2 KB) - added by diver 13 years ago.
back trace

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by korli

It could help to have a backtrace : the problem isn't in the realloc() function obviously.

comment:2 Changed 13 years ago by axeld

What kind of archive was it? "one big file" or "many small files"? If it was the latter, can you retry? Because that might have been fixed in the mean time. Also, it would be helpful for reproducing bugs like these to have a commonly accessible archive, like Mozilla or similar.

Changed 13 years ago by diver

Attachment: Expnader added

back trace

comment:3 Changed 13 years ago by diver

Cc: korli@… added

comment:4 Changed 13 years ago by diver

I think the last comment is another bug in Expander, what do you think Jerome?

comment:5 Changed 12 years ago by jackburton

Description: modified (diff)
Platform: All

This doesn't look like a KDL. The backtrace is the same I have in bug #989. I think we can mark this as fixed (as the KDL does no longer happen) and keep that one instead ?

comment:6 Changed 11 years ago by axeld

Milestone: R1R1/alpha

comment:7 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed since quite some time (should have been a duplicate of #517 anyway).

Note: See TracTickets for help on using tickets.