Opened 10 years ago

Closed 6 years ago

#6052 closed enhancement (fixed)

Larger Cookies.curl slows down page loading

Reported by: humdinger Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #6739, #8682
Has a Patch: no Platform: All

Description

This is Web+ hrev515.

Because I "play back" my settings from Haiku update to update, my Cookies.curl is a bit larger: 126 KiB. This slows down the loading of pages. For example www.haiku-os.org takes about 5 times as long until it's completey loaded, from 4s to 20s.

Change History (7)

comment:1 by stippi, 10 years ago

Wow, thanks for the info. Looks like I really have to code our own cookie implementation... which unfortunately has potential for lots of incompatibilities.

comment:2 by X512, 9 years ago

I have this problem too. My Cookies.curl size is ~200 KB. Page loading is much slower, than with empty Cookies.curl. Cookies must be binary(possible BMessage format) for better perfomance.

comment:3 by alexbl, 9 years ago

This just sounds like the cookiejar is getting reparsed every time you make a request. You needn't change the format of it (indeed the cookiejar format is somewhat standardized anyway), you just need to parse it in and work off an internal representation instead of reparsing it every request.

comment:4 by humdinger, 9 years ago

Blocking: 6739 added

comment:5 by anevilyak, 7 years ago

Blocking: 8682 added

(In #8682) Another duplicate of #6052.

in reply to:  5 comment:6 by Giova84, 7 years ago

Replying to anevilyak:

(In #8682) Another duplicate of #6052.

Sorry, I've performing a search but i have not found this ticket.

Regards.

comment:7 by pulkomandy, 6 years ago

Resolution: fixed
Status: newclosed

Should be solved now, we have switched to our own cookie Jar implementation and the file is read and parsed only once when the browser starts.

Note: See TracTickets for help on using tickets.