Opened 9 years ago

Closed 7 years ago

#6205 closed bug (duplicate)

DHCP stalls boot

Reported by: donn Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/alpha2
Keywords: Cc:
Blocked By: #4239 Blocking:
Has a Patch: no Platform: All

Description

Bootstrap can take several minutes, apparently due to lengthy timeouts in DHCP.

DAEMON 'DHCP': DHCP timeout shift: 8 secs (try 1)
DAEMON 'DHCP': DHCP timeout shift: 8 secs (try 2)
DAEMON 'DHCP': DHCP for /dev/net/marvell_yukon/0, status: Operation timed out
KERN: ata 2 error: timeout waiting for interrupt
KERN: ata 2 error: RecoverLostInterrupt: lost interrupt, status 0x50

Once network server is reconfigured to static, problem goes away.

Initially reported in #5979, because disabling IDE DMA is a sort of workaround (inasmuch as it breaks network server configuration.)

Computer has two network devices, could possibly be related to ticket #5961. First noticed problem in R1/alpha2, but current analysis based on hrev37181.

Attachments (2)

listdev (3.1 KB) - added by donn 9 years ago.
listdev output
marvell_yukon_r44348plus.patch (274 bytes) - added by haxworx 7 years ago.
Fixes all issues on my marvell_yukon from a completely broke driver

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by donn

Attachment: listdev added

listdev output

Changed 7 years ago by haxworx

Fixes all issues on my marvell_yukon from a completely broke driver

comment:1 Changed 7 years ago by haxworx

Has a Patch: set

comment:2 Changed 7 years ago by axeld

Please don't post the same patch to different tickets. Just put a remark in here that you attached a patch to #4239 that fixes the issue here as well instead.

comment:3 Changed 7 years ago by nielx

Has a Patch: unset

comment:4 in reply to:  2 Changed 7 years ago by nielx

Replying to axeld:

Please don't post the same patch to different tickets. Just put a remark in here that you attached a patch to #4239 that fixes the issue here as well instead.

Patch obsoleted per request of axeld.

comment:5 Changed 7 years ago by tqh

Blocked By: 4239 added
Resolution: duplicate
Status: newclosed

Seems to be a duplicate of #4239.

Note: See TracTickets for help on using tickets.