Opened 9 years ago

Closed 7 months ago

Last modified 7 months ago

#6206 closed enhancement (fixed)

Add ScrollBar preference

Reported by: X512 Owned by: jscipione
Priority: normal Milestone: R1
Component: Preferences/Appearance Version: R1/Development
Keywords: Cc: Disreali, Pete
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Original BeOS 5 has it. ScrollBar from BeOS work in Haiku(exept styles). Need to implement it in Haiku.

Change History (24)

comment:1 Changed 9 years ago by Disreali

Cc: mdisreali@… added

The Scrollbar preflet was removed a long time ago. I also would like to see it return. However, I think it should be part of the Appearance preflet as a new tab, and not another preflet by itself.

comment:2 Changed 9 years ago by michaelvoliveira

I don't remember when... but it's around 2005... Haiku will not have ScrollBar pref... double arrows stuff.. nothing. The actual scroll bar is very beautiful for me....

comment:3 in reply to:  2 Changed 9 years ago by X512

Replying to michaelvoliveira:

I don't remember when... but it's around 2005... Haiku will not have ScrollBar pref... double arrows stuff.. nothing. The actual scroll bar is very beautiful for me....

Haiku actually support scrolbar styles, but haven't default configuration program.

comment:4 Changed 9 years ago by stippi

Is there a good argument for having the preflet besides that R5 had it?

comment:5 Changed 9 years ago by X512

Same problem with menu preference.

comment:7 Changed 8 years ago by Pete

I'd like to revive this topic...

One of my most-loved features in BeOS is the double-headed scrollbar arrows. What possible reason could there be for deprecating these? I've always been missing their availability in Haiku -- until I just discovered that I could import the BeOS Preference, and use that to set the appearance.

(I find it annoying on all other OSs to have to move the mouse a long way when I overshoot a scroll.)

I understood that Haiku's current aim was to provide as complete a BeOS experience as possible, so to remove such a valuable feature seems to be crazy!

comment:8 Changed 8 years ago by Pete

Cc: pete.goodeve@… added

comment:9 Changed 8 years ago by stippi

The preferences should be made available in the new Appearance preflet, as Disraeli already mentioned.

comment:10 in reply to:  9 ; Changed 8 years ago by Pete

Replying to stippi:

The preferences should be made available in the new Appearance preflet, as Disraeli already mentioned.

That's good. When's it due...? (:-)) (I think I was spooked by some comments I saw that seemed to indicate people thought it wasn't needed. I also find a link to #522 which said the ScrollBar setting itself didn't work then, but it does now, right? Seems to for me.)

comment:11 in reply to:  10 Changed 8 years ago by Pete

Replying to Pete:

... I also find a link to #522 which said the ScrollBar setting itself didn't work then, but it does now, right? Seems to for me.)

Oh -- I see the problem now. The setting is not preserved across a reboot.

comment:12 Changed 7 years ago by diver

Cc: Disreali Pete added; mdisreali@… pete.goodeve@… removed
Component: PreferencesPreferences/Appearance
Owner: changed from nobody to darkwyrm

comment:13 Changed 7 years ago by diver

Version: R1/alpha2R1/Development

comment:14 Changed 7 years ago by leavengood

I looked into this and it is trivial just to make the double arrows the default, by changing DesktopSettings in the app_server. Given that is a something nice from BeOS I think we should turn it on. It might still be good to have some sort of Scrollbar preference tab eventually, but this is a nice solution for now (for those who like the double arrows at least.)

The only problem I've seen is WebPositive does not look at this setting when it draws its own scrollbars. But that can be fixed.

comment:15 Changed 7 years ago by leavengood

I pushed my changing of the default settings in hrev44236, which re-enables the double arrows.

comment:16 Changed 7 years ago by leavengood

Owner: changed from darkwyrm to leavengood
Status: newassigned

Taking ownership.

comment:17 Changed 6 years ago by jscipione

Brought scroll bar knobs back and revamped the scroll bar settings UI in hrev44733. Web+ still needs to be updated to support cooler scrollbars. However, every useful (IMHO) feature from the Scroll bar preflet has now been reproduced on Haiku.

comment:18 in reply to:  17 Changed 6 years ago by mmadia

Resolution: fixed
Status: assignedclosed

Replying to jscipione:

Brought scroll bar knobs back and revamped the scroll bar settings UI in hrev44733.

Closing as fixed.

comment:19 Changed 15 months ago by jscipione

Resolution: fixed
Status: closedreopened

comment:20 Changed 15 months ago by jscipione

Owner: changed from leavengood to jscipione
Status: reopenedin-progress

comment:21 Changed 7 months ago by jscipione

Resolution: fixed
Status: in-progressclosed

Single/Double scroll bar arrows have already been implemented and now knob styles as well in hrev52106. The only features still missing from BeOS R5 Scroll Bars Preferences are turning off proportional scroll bar knobs (who wants that?) and setting the min knob size (again, who would want that?) which will most-likely never be implemented in Haiku. This ticket is as implemented as it is ever gonna get.

comment:22 in reply to:  21 Changed 7 months ago by khallebal

Replying to jscipione:

and setting the min knob size (again, who would want that?)

I do..! i really liked that in Beos, it was very usefull when scrolling a long document the scroll bar thumb shrinks until it gets too thin to grab with the mouse

comment:23 Changed 7 months ago by waddlesplash

Windows and other OSes have a hard coded minimum knob size. We should probably have that (or do we already?) but I don't see much value in configuring it.

comment:24 Changed 7 months ago by jscipione

The minimum knob size is set by SCROLL_BAR_MINIMUM_KNOB_SIZE which is 9px and is set in headers/os/interface/ScrollBar.h This minimum can be adjusted according to the fPrivateData->fScrollBarInfo.min_knob_size variable in BScrollBar which is what BeOS Scroll Bars Preferences used to set.

Note: See TracTickets for help on using tickets.