Opened 12 years ago

Closed 9 months ago

#6292 closed bug (fixed)

Display Partially Missing: GeForce 6150SE nForce 430 + SAMSUNG 2494SW

Reported by: mmadia Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Haiku-hrev37262-2hybrid.

SAMSUNG 2494SW connected via d-sub to

  • vendor 10de: nVidia Corporation
  • device 03d0: C61 [GeForce 6150SE nForce 430]

The image displays clearly and without distortion. However the only ~1500 x 1080 is viewable, the last ~420 x 1080 pixels are displayed off-screen. The attached image shows at what point the display gets cut off on the monitor -- the mouse icon denotes the start of this region, which has a slightly greyed out.

To note, the 6150SE only provides d-sub.

Testing Haiku-hrev37444-2hybrid on another computer (10de:0393 [GeForce 7300 GT]), both d-sub & DVI display 1920 x 1080 properly.

Attachments (1)

nvidia-grey_area_is_not_visible_on_monitor.png (83.3 KB ) - added by mmadia 12 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 by idefix, 12 years ago

Might be the same bug as described by tbe in comment:ticket:6001:7.

comment:2 by rudolfc, 3 years ago

I think not, we have a general GF 61xx card problem, if I remember correctly,this is a card-type which is integrated on the mainboard of systems. I need such a mainboard to be able to test this card type. Which did not happen yet unfortunately.

The GF61x0 problem is the last remaining (more general) item which should be fixed in the existing nVidia Haiku driver.

Related tickets: #2780, #4670, #6292, #12955.

Last edited 3 years ago by rudolfc (previous) (diff)

comment:3 by rudolfc, 9 months ago

Resolution: fixed
Status: newclosed

For Geforce 6000-6200, notably Nforce 4 and 4xx, but possibly more cards, added detection of a 25Mhz GPU base frequency crystal. This fixes too low refreshrates, wobbly screens, no picture at all, only part of a picture and that kind of trouble.

Fixed in hrev55039.

Closing ticket.

If the problem still exists the ticket can be reopened.

Thanks!

Note: See TracTickets for help on using tickets.