Opened 3 years ago

Last modified 2 months ago

#12955 new bug

NVidia GeForce 6150 (NV44) graphics issues

Reported by: vidrep Owned by: rudolfc
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/nVidia Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev50533 x86_64 ASUS A8N-VM CSM motherboard

  • display showing horizontal lines during boot sequence (attached IMG_0241.JPG)
  • (VGA output) native resolution of monitor (1680x1050) not supported in screen preferences (attached screenshot1.png)
  • (VGA output) selecting any higher resolution than 1024x768 results in distorted image
  • (DVI output) native resolution of monitor is supported in screen preferences, but Haiku auto selects 1024x768 on first boot. (attached screenshot2.png)
  • (DVI output) selecting native monitor resolution (1680x1050) works OK. There are red vertical lines across the desktop. (attached screenshot3.png)

attached syslog_vga attached syslog_dvi attached listdev

Attachments (8)

IMG_0241.JPG (1.6 MB) - added by vidrep 3 years ago.
screenshot1.png (143.4 KB) - added by vidrep 3 years ago.
screenshot2.png (100.7 KB) - added by vidrep 3 years ago.
screenshot3.png (150.9 KB) - added by vidrep 3 years ago.
syslog_vga (121.2 KB) - added by vidrep 3 years ago.
syslog_dvi (119.9 KB) - added by vidrep 3 years ago.
listdev (2.9 KB) - added by vidrep 3 years ago.
nvidia.10de_0240_000500.0.log (173.5 KB) - added by vidrep 11 months ago.

Change History (17)

Changed 3 years ago by vidrep

Attachment: IMG_0241.JPG added

Changed 3 years ago by vidrep

Attachment: screenshot1.png added

Changed 3 years ago by vidrep

Attachment: screenshot2.png added

Changed 3 years ago by vidrep

Attachment: screenshot3.png added

Changed 3 years ago by vidrep

Attachment: syslog_vga added

Changed 3 years ago by vidrep

Attachment: syslog_dvi added

Changed 3 years ago by vidrep

Attachment: listdev added

comment:1 Changed 11 months ago by rudolfc

From the looks of this (the 'lines' in the pictures with the desktop) the card has not enough bandwidth for the DAC/CRTC accessing the graphics ram by default.

The trouble with the native resolution not coming up or not being selectable has something todo with EDID. Possibly your monitor does not report correctly, or possibly the I2C bus wiring for some ports are not known correctly to the driver.

It would be interesting to see the accelerant's own log for this. You can enable full logging via a config file called nvidia.settings. The log will get created in your home folder, something like nv.xxx.0.log (xxx being the /dev/graphics/ name of the driver).

if you can't find the config info you are looking for have a look at my original driver pages here: http://rudolfs-place.nl/BeOS/NVdriver/setinst.html#settings

Last edited 11 months ago by rudolfc (previous) (diff)

comment:2 Changed 11 months ago by vidrep

This NVidia graphics chipset is integrated on the motherboard. Normally this computer serves as my HTPC, so it means pulling it out, swapping HDD and installing Haiku. I'm happy to do it if there's some chance it helps further NVidia graphics support for this chipset. I'll post results as per your instructions within the week.

comment:3 Changed 11 months ago by rudolfc

Yes, I suspected as much, the gfx being integrated. That's also a bit of a problem since I cannot get my hands on such a thing..

Anyhow, if you have enough info to use the settings file and fetch the logfile then this at least gives us a bit more info. If for some reason you cannot get it going please install the driver into the non-system way as I also describe on my pages. Since Haiku has got this protection scheme in place I am kind of in trouble fiddling with the os in a way I can easily work on the drivers for instance..

If your monitor is part of the problem then there's a trick way around that using one of the possible settings in the driver. For the memory problem I need to have a new look at the linux opensource drivers to see if I can find a fix there for your type of card. BTW: the type of system memory used on your mainboard, could that have influence? By that I mean: can you select part of it as display memory for the gfx, trough the BIOS? If so, a faster type might just have some influence..

comment:4 Changed 11 months ago by vidrep

Is there any way to enable logging with the Nvidia driver that comes with Haiku, or must I use the old driver found on your webpage? I've tried both, but neither creates a log. I've also tried renaming the settings file from nv.config to nvidia.config. Any suggestions?

comment:5 Changed 11 months ago by rudolfc

Hi, I just tested it on my fresh installed very recent Haiku hybrid image. Works perfectly. Just create a textfile called nvidia.settings in your ~/config/settings/kernel/drivers/ folder. It needs just one single activated line for you at this moment: logmask 0xffffffff

Reboot, grab the new file created in your home folder called something like: nvidia.10de_0140_010000.0.log And post it here. Thank you :)

comment:6 Changed 11 months ago by vidrep

That worked. The log is attached.

Changed 11 months ago by vidrep

comment:7 Changed 11 months ago by rudolfc

From the log I see two problems that need to be solved:

  1. I2C buses are not found/configured correctly (no EDID readable therefore)
  2. CAS RAM access errors, indeed detected by the driver, tuning is needed, but the needed code is unknown.

I'll try to find info in the/a linux project for these problems. Last time I looked (is some time ago indeed..) this was not yet known. I'll get back to you on this. Thanks for the log!

comment:8 Changed 11 months ago by vidrep

Thanks for the prompt reply. I'll be returning that computer to HTPC service, but can pull it again for testing once you think you might have a solution in hand. Whatever I can do to help further hardware support for Haiku.

comment:9 Changed 2 months ago by rudolfc

We have a general GF 61xx card problem, if I remember correctly,this is a card-type which is integrated on the mainboard of systems. I need such a mainboard to be able to test this card type. Which did not happen yet unfortunately.

The GF61x0 problem is the last remaining item which should be fixed in the existing nVidia Haiku driver.

Related tickets: #2780, #4670, #6292, #12955.

Note: See TracTickets for help on using tickets.