Opened 9 years ago

Closed 6 years ago

#6473 closed bug (fixed)

Google mail problems

Reported by: 2ck Owned by: stippi
Priority: blocker Milestone: R1
Component: Applications/WebPositive Version: R1/alpha2
Keywords: r488 Cc:
Blocked By: Blocking: #7823, #8813, #8968, #9146
Has a Patch: no Platform: All

Description

Google mail doesn't function properly with, at least, this version of web positive. An error occurs when sending mail through the standard interface with a prompt to retry, and a general error notification appears at the top of the window designated '#500'. The HTML interface seems to work fine.

Change History (12)

comment:1 Changed 9 years ago by 2ck

The error indicates a browser problem but has no specific, stated cause.

comment:2 Changed 9 years ago by anevilyak

This is a known issue that's most likely due to problems with AJAX handling. It's possibly a bug in the libcurl backend that Web+'s WebKit implementation is currently using, and may be fixed when it's switched over to using the services kit (though that will have to wait partly until services kit has https support, since that's required for gmail authentication).

comment:3 Changed 9 years ago by humdinger

Until this is fixed, GMail is still usable when viewed in "Simple HTML" mode.

comment:4 Changed 8 years ago by anevilyak

Blocking: 7823 added

(In #7823) Duplicate of #6473.

comment:5 Changed 8 years ago by dsuden

Using build 583 of W+ and Haiku build 42714, I can't bring up the Google Mail web page at all. It will bring up other Google pages but not that one. It doesn't even start to load the page as far as I can see. Just sits there with a partial progress bar that never moves.

comment:6 Changed 7 years ago by dsuden

With build 586 of W+ and Haiku build 44016, there's a big improvement. Everything seems to work well EXCEPT for when you hit send on an e-mail message. Then it returns the following message in a little window:

"Your action was unsuccessful. Please try again."

comment:7 Changed 7 years ago by anevilyak

Blocking: 8813 added

(In #8813) Duplicate of #6473.

comment:8 Changed 7 years ago by aldeck

Priority: normalblocker

comment:9 Changed 7 years ago by anevilyak

Blocking: 8968 added

(In #8968) Facebook chat is due to the same issue as #6473.

comment:10 Changed 7 years ago by anevilyak

Blocking: 9146 added

(In #9146) Same underlying issues as #6473.

comment:11 Changed 6 years ago by waddlesplash

With the new WebKit, this seems to work fine for me (albeit with a ton of rendering problems). Functionality seems correct, though.

comment:12 Changed 6 years ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.