Opened 9 years ago

Closed 6 years ago

#6717 closed bug (fixed)

Terminal: character problems

Reported by: MichaelPeppers Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: Cc: siarzhuk
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev38969, the Terminal doesn't complete showing some paths if there are japanese characters in it, except if you start writing something.

Other odd stuff happens, but probably the screenshots can explain the problems better than me.

Attachments (5)

PathNotCompleted.jpeg (20.4 KB) - added by MichaelPeppers 9 years ago.
PathNotCompleted2.jpeg (21.5 KB) - added by MichaelPeppers 9 years ago.
Listdev.jpg (75.3 KB) - added by MichaelPeppers 9 years ago.
Test2.jpeg (20.7 KB) - added by MichaelPeppers 9 years ago.
Test3.png (12.5 KB) - added by MichaelPeppers 9 years ago.
hrev40145, Test2.png + deleting the writing using the backspace. As you can see, the path line jumps into a previous line.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by MichaelPeppers

Attachment: PathNotCompleted.jpeg added

Changed 9 years ago by MichaelPeppers

Attachment: PathNotCompleted2.jpeg added

Changed 9 years ago by MichaelPeppers

Attachment: Listdev.jpg added

Changed 9 years ago by MichaelPeppers

Attachment: Test2.jpeg added

comment:1 Changed 9 years ago by MichaelPeppers

Test2.jpeg shows what happens if you write something longer than the current line in this particular case. Same effect as bug #6387, (apparently) different cause.

Last edited 9 years ago by MichaelPeppers (previous) (diff)

comment:2 Changed 9 years ago by MichaelPeppers

Forgot to say, a character from the folder name is missing from the Japanese character set in Haiku. Maybe that could be the reason of these problems.

Last edited 9 years ago by MichaelPeppers (previous) (diff)

comment:3 Changed 9 years ago by bonefish

At least part of this is related to #6276.

Changed 9 years ago by MichaelPeppers

Attachment: Test3.png added

hrev40145, Test2.png + deleting the writing using the backspace. As you can see, the path line jumps into a previous line.

comment:4 Changed 9 years ago by MichaelPeppers

Time to test with hrev40174, aye?

comment:5 Changed 8 years ago by siarzhuk

Cc: siarzhuk added

comment:6 Changed 8 years ago by luroh

MichaelPeppers: could you please retest with hrev45307 or later?

comment:7 in reply to:  6 Changed 8 years ago by MichaelPeppers

Replying to luroh:

MichaelPeppers: could you please retest with hrev45307 or later?

Unfortunately not at the moment... I'll be back to my main pc approximately after the first week of January; anyway, I think siarzhuk should be able to test whether it's been solved before I can.

If that's not the case I will try to reproduce it as soon as I can.

comment:8 Changed 6 years ago by siarzhuk

Owner: changed from jackburton to siarzhuk
Status: newassigned

comment:9 Changed 6 years ago by siarzhuk

Resolution: fixed
Status: assignedclosed

East Asian Full-Width characters support fixed in hrev45462. The issue should be fixed now.

Note: See TracTickets for help on using tickets.