Opened 7 years ago

Closed 5 years ago

#8638 closed bug (fixed)

KDL During install-wifi-firmwares.sh / WPA Join -> No Link

Reported by: br3wski3 Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: wifi firmwares wpa Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have had R1/alpha3 installed for some while on a Dell Inspiron 600m. I recently became interested in trying to get the Wifi to work on it as that's all that is available in my household. I installed the firmwares that come pre-packaged via the install-wifi-firmwares.sh only to subsequently find that the hardware was successfully detected but WPA, which we use, is not. I found that the latest development has support for WPA so performed an upgrade via hrev44241 nightly install media. Hardware remains detected but performing the join this time around yields no error via ifconfig but the network applet quickly notifies me of no-link status. I decided to try to run install-wifi-firmwares.sh again in case there are newer versions but it throws me into KDL (which I have zero experience with).

All that said, I'm not completely sure what to provide (I have perused the docs a bit but not sure what pieces to provide); anyway, I'd be happy to re-produce and provide output as needed including snippets of the syslog, just let me know what's needed! It is a little difficult though since I have to transfer off whatever's needed :)

Thanks for help, thoughts, and all else.

-Brendan

Attachments (6)

syslog.120615.2211 (512.1 KB) - added by br3wski3 7 years ago.
P1000318_Cropped.JPG (4.5 MB) - added by br3wski3 7 years ago.
iprowifi2200.txt (410 bytes) - added by br3wski3 7 years ago.
cmds.120618.1025.txt (23.9 KB) - added by br3wski3 7 years ago.
syslog.120618.1025.snip.txt (93.9 KB) - added by br3wski3 7 years ago.
haiku-error-after-install_wifi_sh.png (10.8 KB) - added by br3wski3 5 years ago.

Change History (21)

comment:1 Changed 7 years ago by diver

If hardware is already detected and the nic is shown in ifconfig (or Network preflet) then there is no need to run install-wifi-firmwares.sh. That being said the KDL is still interesting, could you take a photo of it? Also please attach your syslog.

Changed 7 years ago by br3wski3

Attachment: syslog.120615.2211 added

Changed 7 years ago by br3wski3

Attachment: P1000318_Cropped.JPG added

comment:2 Changed 7 years ago by br3wski3

Hi diver,

Thanks for the response! I've attached the requested files.

In producing the entries in the syslog, I cleared the old one, rebooted, did an 'ifconfig up' and 'ifconfig join' on my wireless device which yielded the aforementioned no-link status after a short time thereby reproducing the issue with my card not working as I'd hoped. I then tried the install-wifi-firmwares.sh a couple times without being kicked into KDL (which had previously been reproduced every time I tried it). I subsequently rebooted and tried the installer shell script right away which then reproduced the KDL issue. Attached is the photo of this. After getting the photo, I rebooted and grabbed the syslog which is attached as well and contains info for everything described.

Please let me know if there is any further info I can provide.

Thanks!

-Brendan

comment:3 Changed 7 years ago by diver

Judging from the screenshot the KDL seems to happen when install-wifi-firmwares.sh tries to reload iprowifi2200 driver and looks similar to #7000. Looking at your syslog I noticed:

[iprowifi2200] (iwi) firmware error

So make sure that /system/data/firmware/iprowifi2200 directory contains the following files:

ipw2200-bss.fw
ipw2200-fw-3.1.tgz
ipw2200-ibss.fw
ipw2200-sniffer.fw
LICENSE.ipw2200-fw

Changed 7 years ago by br3wski3

Attachment: iprowifi2200.txt added

comment:4 Changed 7 years ago by br3wski3

Hi diver,

I can agree that there seems to be some similarity with #7000 but can't speak to that very well :) I did notice that the other ticket has been open for some time and seeing as there appears to be some similarity here, I'm just curious about potential resolution.

I have attached a listing of my iprowifi2200 directory which looks to contain all the files you listed above. Any other thoughts?

Thanks, -Brendan

comment:5 Changed 7 years ago by diver

You can try to start net_server from Terminal and maybe you'll be able to see some additional debug output:

hey net_server quit
/system/servers/net_server

Also start watching syslog messages using:

tail -F /var/log/syslog

...in another Terminal window. Use grep -ve foo -ve bar to filter out useless messages.
Then try to connect to your network using ifconfig join.
I'm not sure what exactly you should look for, but maybe there will be some hints.

Last edited 7 years ago by diver (previous) (diff)

Changed 7 years ago by br3wski3

Attachment: cmds.120618.1025.txt added

Changed 7 years ago by br3wski3

Attachment: syslog.120618.1025.snip.txt added

comment:6 Changed 7 years ago by br3wski3

Hi diver,

I've attached terminal output as directed in the cmds file which also includes the 'ifconfig up' and 'ifconfig join'. To support this, as requested, I've attached a snippet of my syslog as obtained via tail during my command operations.

Thanks, -Brendan

comment:7 Changed 7 years ago by diver

That should be enough information for the developers to look in. Out of curiosity you might try hrev43740 which contains a previous version of iprowifi2200 driver. Also you can try to change encryption type (or even ssid) on your AP and see if it makes any different. Good luck!

Last edited 7 years ago by diver (previous) (diff)

comment:8 Changed 7 years ago by br3wski3

Hi diver,

Thank you yet again for your feedback.

I have tried hrev43740 as suggested but it did not contain the wpa_supplicant (as I realized after getting the "Application could not be found" message upon my 'ifconfig join' attempt). So, I mounted my internal HD Haiku partition (running the requested rev on a USB drive for this test) and copied it (via a 'cp -p') into the appropriate location. After this, I re-tried the join attempt but, unfortunately, do not appear to be any better off :(

I would normally be open to altering the encryption type and/or ssid but the AP is one of my roommates and I also don't think any of them would be impressed with my playing around rendering them without internet temporarily/intermittently. So, I'm going to hold off on that option unless someone thinks it could be really useful to try out!

All are welcome let me know if there is anything else I can do or provide and I'd be happy to do so.

Thanks, -Brendan

comment:9 Changed 5 years ago by luroh

br3wski3, any improvement here with a recent nightly?

comment:10 Changed 5 years ago by br3wski3

Now that #10464 has been re-closed, I intend to take a look at seeing if I can look back into this.

-br3wski3

Changed 5 years ago by br3wski3

comment:11 Changed 5 years ago by br3wski3

Ok, so I tried out hrev47749. After running install-wifi-firmwares.sh, I got the following error with no WiFi card detection -

Package Daemon refreshing repository "Haiku" failed: General system error

-br3wski3

Last edited 5 years ago by diver (previous) (diff)

comment:12 Changed 5 years ago by diver

Does it work after reboot maybe? In any event, please attach your syslog.

comment:13 Changed 5 years ago by luroh

Yeah, I noticed the same thing. The user experience is still rough but it should at least work after a reboot.

comment:14 Changed 5 years ago by br3wski3

diver/luroh, thanks for your responses.

Yes, a reboot addresses the issue noted previously with the package daemon. Is it preferable to follow up on this ticket for this other issue or would it be better to open a separate ticket and/or follow up on another ticket that you may know of (with the syslog and so on)?

Anyway, with regard to this ticket and the originally reported issue, other than running into #10914 and having to re-copy the hpkg in place for it to re-load after un-load, I no longer seem to have this issue with being thrown into KDL.

-br3wski3

comment:15 Changed 5 years ago by luroh

Resolution: fixed
Status: newclosed

br3wski3, thanks for checking.

I have searched but not been able to find any ticket for the 'refreshing repository' error, so please feel free to file one against the servers/package_daemon component. Please attach the picture and include the text as well (to make it searchable). I'm guessing that adding a hpkg to /boot/system/packages triggers the package daemon to try refreshing the repos, which fails since the laptop is still offline (until a reboot has taken place and the firmware has been loaded).

Note: See TracTickets for help on using tickets.