Opened 7 years ago

Closed 7 years ago

#9058 closed bug (fixed)

[Trac] "Has a Patch" no longer working

Reported by: umccullough Owned by: nielx
Priority: high Milestone:
Component: Website/Trac Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

It seems the "Has a Patch" functionality is no longer working properly in Trac.

The checkbox is there, but doesn't appear to be usable - furthermore, when someone comments on a ticket containing a patch, where "Has a Patch" is checked, it seems to uncheck it automatically.

Attachments (3)

configure-preview-limit-by-mimetype.diff (2.1 KB) - added by nielx 7 years ago.
Test
hgshelve.py (21.1 KB) - added by nielx 7 years ago.
Another test
ticket_9058_snip.PNG (12.8 KB) - added by umccullough 7 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 7 years ago by umccullough

Tickets potentially affected since 2012-10-08 (according to my haiku-bugs emails):

#8007 #8900 #9043

edit: removed the already-closed tickets since those patches have been applied anyhow.

Last edited 7 years ago by umccullough (previous) (diff)

comment:2 Changed 7 years ago by bonefish

Owner: changed from haiku-web to nielx
Status: newassigned

Changed 7 years ago by nielx

Test

comment:3 Changed 7 years ago by nielx

Has a Patch: set

comment:4 Changed 7 years ago by nielx

Has a Patch: unset

This is a comment after setting a patch

Changed 7 years ago by nielx

Attachment: hgshelve.py added

Another test

comment:5 Changed 7 years ago by nielx

Has a Patch: set

comment:6 Changed 7 years ago by nielx

Test removal

comment:7 Changed 7 years ago by nielx

This is fixed in attachment flags 0.1.3 and deployed here.

comment:8 Changed 7 years ago by nielx

Resolution: fixed
Status: assignedclosed

Changed 7 years ago by umccullough

Attachment: ticket_9058_snip.PNG added

comment:9 Changed 7 years ago by umccullough

Only one minor nit:

In the "Modify Ticket" interface, it doesn't display properly when there's no patch set yet (after checking and saving, it looks fine).

comment:10 Changed 7 years ago by nielx

Has a Patch: unset

Ah yes. There was a flaw in the logic of the patch. It should really be fixed now.

comment:11 in reply to:  10 Changed 7 years ago by umccullough

Resolution: fixed
Status: closedreopened

Replying to nielx:

Ah yes. There was a flaw in the logic of the patch. It should really be fixed now.

Are you sure?

Now it seems to be back to the original behavior :(

comment:12 Changed 7 years ago by nielx

Has a Patch: set

comment:13 Changed 7 years ago by luroh

Has a Patch: unset

#4494 affected

comment:14 Changed 7 years ago by umccullough

#9071 affected

comment:15 Changed 7 years ago by umccullough

#8345 affected

comment:16 Changed 7 years ago by nielx

Has a Patch: set

comment:17 Changed 7 years ago by nielx

Resolution: fixed
Status: reopenedclosed

Updated #9071 #8345

Fixed now. I tested various possibilities on my local machine and I am confident I nailed it now. Let me know if it turns out to still cause issues.

Note: See TracTickets for help on using tickets.