Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11001 closed bug (fixed)

Drawing issues of widgets on 'tall' pages

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1/beta1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11095, #11133
Has a Patch: no Platform: All

Description

This is hrev47460.

The latest Web+ has issues drawing pop-up menus and buttons, also the comment text field doesn't render text and is very slow on resizing. See ticket #10840 as example.

From IRC:

[17:25] <PulkoMandy> I think there is one problem at the edge of texture tiles (every 2048 pixels), but I've not reproduced it reliably yet
[17:26] <humdinger> https://dev.haiku-os.org/ticket/10839 looks as expected.
[17:26] <humdinger> #10840 has many embedded images.
[17:27] <PulkoMandy> yes, so that's it
[17:27] <PulkoMandy> the bug does not show in the first 2048 pixels of the page, so you need one long enough

Attachments (4)

TracTicket.png (46.9 KB ) - added by taos 5 years ago.
TracTicket in Webpositive on hrev47753.
upper_part.png (240.9 KB ) - added by taos 5 years ago.
Rendering of upper part of www.spiegel.de
lower_part.png (129.8 KB ) - added by taos 5 years ago.
Rendering of lower part of www.spiegel.de
WebPositive-922-debug-11-09-2014-19-17-34.report (78.5 KB ) - added by taos 5 years ago.
report file for frozen WebPositive

Download all attachments as: .zip

Change History (13)

comment:1 by pulkomandy, 5 years ago

Milestone: R1R1/alpha5

comment:2 by pulkomandy, 5 years ago

Blocking: 11095 added

comment:3 by humdinger, 5 years ago

Blocking: 11133 added

comment:4 by taos, 5 years ago

With HaikuWebKit 1.4.2, pages such as http://haiku-os.org/community/forum/qt_53_haiku_progress or http://www.heise.de look even worse. It's also got really difficult to add a comment here because you can no longer see what you're typing or which button you have to push...

TracTicket in Webpositive on hrev47753.

I'm running hrev47753 at the moment.

Last edited 5 years ago by taos (previous) (diff)

by taos, 5 years ago

Attachment: TracTicket.png added

TracTicket in Webpositive on hrev47753.

comment:5 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Will be fixed in the next release (1.4.4).

comment:6 by taos, 5 years ago

Using HaikuWebkit 1.4.4 in hrev47850 gcc2h, I'm not sure if all problems with "tall" pages are solved. While the websites mentioned in this ticket do look fine now, I've encountered another one (http://www.spiegel.de), that looks really strange: Rendering of upper part of www.spiegel.de Rendering of lower part of www.spiegel.de In the upper part everything looks okay, however, in the lower part text looks a little pixelated (that's the part you couldn't see at all with 1.4.3). Additionally, if you scroll further down, WebPositive freezes quite often (debug report attached).

by taos, 5 years ago

Attachment: upper_part.png added

Rendering of upper part of www.spiegel.de

by taos, 5 years ago

Attachment: lower_part.png added

Rendering of lower part of www.spiegel.de

by taos, 5 years ago

report file for frozen WebPositive

comment:7 by pulkomandy, 5 years ago

This is a different issue, please open a new ticket. The problem has nothing to do with the page being tall, but with these parts being layers which can be scrolled left/right using the buttons at the bottom and us not handling that quite right yet.

in reply to:  7 comment:8 by taos, 5 years ago

Replying to pulkomandy:

This is a different issue, please open a new ticket. The problem has nothing to do with the page being tall, but with these parts being layers which can be scrolled left/right using the buttons at the bottom and us not handling that quite right yet.

I opened a new ticket for this issue: #11231.

comment:9 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.