Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3847 closed bug (fixed)

Boot Fail

Reported by: HaikuBot Owned by: axeld
Priority: blocker Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: HubertNG@…, black.belt.jimmy@…
Blocked By: Blocking: #3857, #3869, #3871
Has a Patch: no Platform: All

Description

I use Haiku on my laptop (Acer Travelmate 2493). Unfortunately, since hrev30515 Haiku going in KDL. (See attachment)

Attachments (16)

KDL.jpg (484.3 KB ) - added by HaikuBot 11 years ago.
threads.JPG (477.4 KB ) - added by HaikuBot 11 years ago.
syslog1.JPG (437.6 KB ) - added by HaikuBot 11 years ago.
syslog2.JPG (479.2 KB ) - added by HaikuBot 11 years ago.
syslog3.JPG (449.8 KB ) - added by HaikuBot 11 years ago.
syslog4.JPG (471.4 KB ) - added by HaikuBot 11 years ago.
syslog5.JPG (458.7 KB ) - added by HaikuBot 11 years ago.
syslog6.JPG (462.0 KB ) - added by HaikuBot 11 years ago.
syslog7.JPG (461.9 KB ) - added by HaikuBot 11 years ago.
syslog8.JPG (453.6 KB ) - added by HaikuBot 11 years ago.
syslog9.JPG (394.4 KB ) - added by HaikuBot 11 years ago.
syslog10.JPG (327.5 KB ) - added by HaikuBot 11 years ago.
syslog11.JPG (335.1 KB ) - added by HaikuBot 11 years ago.
syslog12.JPG (405.7 KB ) - added by HaikuBot 11 years ago.
syslog13.JPG (353.1 KB ) - added by HaikuBot 11 years ago.
error_boot.jpg (51.0 KB ) - added by miltoncsl 11 years ago.

Change History (38)

by HaikuBot, 11 years ago

Attachment: KDL.jpg added

comment:1 by stippi, 11 years ago

Component: - GeneralSystem/Kernel
Milestone: R1R1/alpha1
Priority: normalblocker

comment:2 by stippi, 11 years ago

If I am not mistaken, the other pre-fetching bug was re-opened mistakenly and then closed again, but no new bug was created? If it was, then this is a duplicate, but otherwise, the bug can be tracked in this ticket.

comment:3 by axeld, 11 years ago

Can you please tell how much memory your laptop has? This is a very weird bug, and I can't see how this should happen - it means the cache was deleted during the I/O, which should be impossible considering that the calling code as well as the precaching code owns a reference to it.

Are you building the images yourselves? Is this a clean build? When exactly does the problem appear? What's the output of the "syslog" and "threads" commands in KDL?

comment:4 by HaikuBot, 11 years ago

Laptop has 1Gb DDR2 533, Intel Celeron M 1730 Mhz, Intel GMA 950, 120 Gb HDD. Yep, i`m build by myself. Yes, clean build, I also try raw image hrev30526 from haiku-files.org. Haiku going in KDL after last boot icon (rocket). Output of syslog and threads in attachments.

by HaikuBot, 11 years ago

Attachment: threads.JPG added

by HaikuBot, 11 years ago

Attachment: syslog1.JPG added

by HaikuBot, 11 years ago

Attachment: syslog2.JPG added

by HaikuBot, 11 years ago

Attachment: syslog3.JPG added

by HaikuBot, 11 years ago

Attachment: syslog4.JPG added

by HaikuBot, 11 years ago

Attachment: syslog5.JPG added

by HaikuBot, 11 years ago

Attachment: syslog6.JPG added

by HaikuBot, 11 years ago

Attachment: syslog7.JPG added

by HaikuBot, 11 years ago

Attachment: syslog8.JPG added

by HaikuBot, 11 years ago

Attachment: syslog9.JPG added

by HaikuBot, 11 years ago

Attachment: syslog10.JPG added

by HaikuBot, 11 years ago

Attachment: syslog11.JPG added

by HaikuBot, 11 years ago

Attachment: syslog12.JPG added

by HaikuBot, 11 years ago

Attachment: syslog13.JPG added

comment:5 by HaiColon, 11 years ago

I get the same error on my computer, at least I'm 99% sure. I can't take a picture of it since I don't have a digital camera. From the things I do remember from the stacktrace output it seems to be exactly the same error, goes into KDL after the last boot icon like HaikuBot said.

I did a jam clean before building, gcc2 build, 1.5 GB RAM, Gigabyte k8nmf-9 Mainboard, Athlon XP 3200+ CPU.

comment:6 by anevilyak, 11 years ago

Blocking: 3857 added

(In #3857) Duplicate of #3847.

comment:7 by anevilyak, 11 years ago

Blocking: 3853 added

(In #3853) That would be ticket #3847. Closing this one as it no longer serves any purpose of its own.

comment:8 by kvdman, 11 years ago

Blocking: 1599 added

comment:6 by oco, 11 years ago

Blocking: 1599, 3853, 3857 removed

I reproduce it on my new laptop with hrev30563. This laptop is a dual-core with 4 Gb of memory. I am not able to reproduce it on my older one with 512 Mb.
I is my own build, compiled under Haiku. I boot from a USB hard drive. I will add some more informations later (syslog and threads).

comment:7 by kvdman, 11 years ago

Why was 1599 blocking removed? 1599 hasn't been closed and this bug is blocking Haiku from booting on Macs.

comment:8 by anevilyak, 11 years ago

Blocking: 1599, 3853, 3857 added

Probably an accidental edit on oco's part. Reinstated previous blocker list.

comment:9 by axeld, 11 years ago

Blocking: 1599, 3853 removed

Those bugs have *nothing* to do with this bug, so removing from the blocking ones.

by miltoncsl, 11 years ago

Attachment: error_boot.jpg added

comment:10 by diver, 11 years ago

Same here on my eeepc 900.

comment:11 by anevilyak, 11 years ago

Blocking: 3869 added

(In #3869) Duplicate of ticket #3847.

comment:15 by Hubert, 11 years ago

Cc: HubertNG@… added

comment:16 by miltoncsl, 11 years ago

Hi,

I have other notebook with the follow config:

Processor: Celeron M430 1.73 GHz Cache: 1024 KB Memory: 256 MB HD: 40 GB

00:00.0 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge 00:00.1 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge 00:00.2 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge 00:00.3 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge 00:00.4 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge 00:00.5 PIC: VIA Technologies, Inc. CN896/VN896/P4M900 I/O APIC Interrupt Controller 00:00.6 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Security Device 00:00.7 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge 00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge 00:02.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80) 00:03.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80) 00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80) 00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07) 00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0) 00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0) 00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0) 00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0) 00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86) 00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge 00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller 00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c) 00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge 00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge 01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01) 06:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10) 07:04.0 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller 07:04.1 SD Host controller: ENE Technology Inc ENE PCI SmartMedia / xD Card Reader Controller 07:04.3 FLASH memory: ENE Technology Inc ENE PCI Secure Digital / MMC Card Reader Controller

And show similar error (attached photo)!

This error arose in hrev30475!

comment:17 by anevilyak, 11 years ago

Blocking: 3871 added

(In #3871) Duplicate of ticket #3847.

comment:18 by bbjimmy, 11 years ago

Cc: black.belt.jimmy@… added

comment:19 by axeld, 11 years ago

Status: newassigned

I can finally reproduce the problem with qemu and the CD build.

comment:20 by axeld, 11 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev30632.

comment:21 by HaikuBot, 11 years ago

Thanks Axel.

comment:22 by HaikuBot, 11 years ago

Also close this one #3703.

Note: See TracTickets for help on using tickets.