Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4831 closed bug (duplicate)

Tracker crash with New Mail query

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: #4130 Blocking:
Has a Patch: no Platform: All

Description

This is hrev33708.

I have a query for new mail open at all times.
Every 5 minutes the mail_daemon gathers new mail. Every once in a while, maybe once an hour, newly arrived mail is crashing Tracker. Probably when inserting new entries in the New Mail query result window. This is the backtrace:

[Switching to team /boot/system/Tracker (110) thread w>New E-mail (184)]
0x00513c2c in BPrivate::Model::StatChanged ()
   from /boot/system/lib/libtracker.so
(gdb) bt
#0  0x00513c2c in BPrivate::Model::StatChanged ()
   from /boot/system/lib/libtracker.so
#1  0x00539093 in BPrivate::BPoseView::AttributeChanged ()
   from /boot/system/lib/libtracker.so
#2  0x00539d70 in BPrivate::BPoseView::FSNotification ()
   from /boot/system/lib/libtracker.so
#3  0x00542d07 in BPrivate::BPoseView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#4  0x0054a46f in BPrivate::BQueryPoseView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#5  0x002a878d in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#6  0x0035e932 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#7  0x0035a329 in BWindow::task_looper () from /boot/system/lib/libbe.so
#8  0x002a9fb0 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#9  0x005eb7bd in thread_entry () from /boot/system/lib/libroot.so
#10 0x70184fec in ?? ()

Change History (3)

comment:1 Changed 10 years ago by aldeck

Duplicate of #4610 and #4130 and possibly #4130 too (not sure which one to keep yet). Please keep your setup as is as you seem to have a somewhat reproducible case (the same usage on my machine don't show the bug). Looking into it (again:))

comment:2 Changed 10 years ago by aldeck

Blocked By: 4130 added
Resolution: duplicate
Status: newclosed

Duplicate of #4130, fixed by hrev33744.

for reference, the last bug i wanted to refer to in the previous comment was #4271.

comment:3 Changed 10 years ago by humdinger

I confirm, this looks like it's fixed with the hrev33755 I have here. Thanks very much!

Note: See TracTickets for help on using tickets.