Opened 9 years ago

Closed 8 years ago

#5720 closed bug (duplicate)

Cant boot instaler!

Reported by: bfshadow Owned by: axeld
Priority: normal Milestone: R1/alpha3
Component: System/Boot Loader Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Haiku CD burned into a DVD

insert and power on the computer

BIOS screen...ok Booting... Black screen with a _ blinking near the center screen

Celeron 800 MHZ Ram 128MB(single) HD 40GB Seagate Xubuntu 9 DVD rom NO Floppy

first Boot Device CD/DVD

Change History (16)

comment:1 by starsseed, 9 years ago

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld
Priority: highnormal

#5696 seems to be similar since it hangs at the same early stage before the boot menu

comment:2 by xsive, 9 years ago

Yeah exactly same problem for me, reported it in ticket #5539. Still can't get it working. Tried changing bios options and everything else I can think of :(

comment:3 by mmadia, 9 years ago

is this with R1 Alpha 1 or a newer nightly?

comment:4 by xsive, 9 years ago

for me it does it with both the alpha and nightly builds

comment:5 by starsseed, 9 years ago

I used to get the boot menu with hrev33411 (~1 month after Alpha1 : see #5696 for details)

NB: My professional laptop doesn't works when my brother's laptop works like a charm, wheras both are based on the same "Intel 45 Express" chipset !

comment:6 by bonefish, 9 years ago

Milestone: R1R1/alpha2
Version: R1/alpha1R1/Development

comment:7 by starsseed, 9 years ago

Blocked By: 4408 added

comment:8 by stippi, 9 years ago

This computer has only 128 MiB RAM. Has the behavior changed in recent revisions? There were some fixes which may allow it to boot now.

comment:9 by xsive, 9 years ago

I've tried latest release and I still have the problem, although last night it let me get into boot options once and I managed to boot. However on the next boot I couldn't get into boot options again just hung, very strange.

comment:10 by xsive, 9 years ago

So confused by this, just tried the latest nightly build, and as last comment I could enter the boot options once, when I restarted it couldn't do it again! Don't know why it let me first time but not again... and it was by pressing space bar not shift key.

comment:11 by scottmc, 9 years ago

Can you try this again with a more recent build? How many minutes did you let it go before giving up?

How much memory in the PC now? Any hard drive in the system? Any devices connected via USB? Any SCSI bus in the PC? Does the BIOS on the PC allow for booting from a CD? DVD? Please give as many details as you can.

comment:12 by xsive, 9 years ago

I've tried myself with a recent build but same, just blinking caret in center of the screen after the dots. My PC has 2GB ram, mouse and keyboard only in the USB, nvidia 9800gtx gfx. This happens when booting from the live CD and from USB flash drive.

comment:13 by xsive, 9 years ago

oh and I've left it for like an hour or so and went back and it was still the same hadn't moved any further on, still can't get into safe options either

comment:14 by phoudoin, 9 years ago

Considering this issue (and related) seems hard to reproduce by developers and difficult to record usefull details by its victims, can some of them be brave enough to try narrow down a bit the range of revisions from which it was still working and after which it doesn't anymore?

It seems to happen during stage1 or very early stage2 boot loading phase, and these areas were changed up to last.

For instance one could try to bisect according to these changeset: http://dev.haiku-os.org/browser/haiku/trunk/src/system/boot/platform/bios_ia32?order=date

Does hrev33670 still works. hrev34542? hrev35815? hrev36233? hrev37249?

I hope haiku-files.org still hosts these images, BTW.

Also, it would be a good idea that people having this issue or very similar could report which gcc flavor they're using.

comment:15 by pulkomandy, 8 years ago

Blocked By: 4408 removed

comment:16 by pulkomandy, 8 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3441.

Note: See TracTickets for help on using tickets.