Opened 9 years ago

Last modified 2 years ago

#5812 reopened bug

[FileTypes] alt+s doesn't work in "appliation type" window

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/FileTypes Version: R1/Development
Keywords: Cc:
Blocked By: #12780 Blocking: #6860
Has a Patch: Platform: All

Description

Open any app using FileTypes tracker add-on.
Change something in description.
Press Alt+s to save changes.
Press Alt+w to close window.
You will see an alert about unsaved changes.

Tested with hrev36474 in VirtualBox 3.0.12.

Attachments (1)

0001-filetypes-saving.patch (4.1 KB) - added by siarzhuk 5 years ago.
Result of corresponding GCI 2013 task

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by axeld

Blocking: 6860 added

(In #6860) Thanks for the note.

comment:2 Changed 5 years ago by Freeman

So I tested FileTypes and found the following:

-If you change any other parameter along with the description, it will save and allow you to exit without the popup -If you change any other parameter without changing the description, it will save and you can exit without popup -The weird thing is that when you save from the popup, it calls the same save function, but now the description is actually written.

comment:3 Changed 5 years ago by Freeman

The creator never made a msg for the Version text controls, so users never actually get to save the first time if they only edited the version part.

Last edited 5 years ago by Freeman (previous) (diff)

Changed 5 years ago by siarzhuk

Attachment: 0001-filetypes-saving.patch added

Result of corresponding GCI 2013 task

comment:4 Changed 5 years ago by siarzhuk

Has a Patch: set

comment:5 Changed 3 years ago by diver

Blocked By: 12780 added
Resolution: duplicate
Status: newclosed

comment:6 Changed 3 years ago by jscipione

Resolution: duplicate
Status: closedreopened

This is a slightly different issue from #12780. That bug is about the change version info not triggering a save, this bug is about the Alt+S shortcut not working while focused on the the description field. I tested this and it seems to be an issue once again.

comment:7 Changed 2 years ago by diver

Blocking: 13225 added

(In #13225) Dupe of #5812.

comment:8 Changed 2 years ago by pulkomandy

Has a Patch: unset

comment:9 Changed 2 years ago by pulkomandy

Has a Patch: unset

1) Marking the patch as obsolete, because it does not apply anymore, and the problem with the "version" field was already solved. 2) The behavior of not accepting changes in a BTextView is strange, but it is standard in Haiku. BTextView is Invoke()d when you press enter in a single line control, and when it losts focus after a change, only. This makes various things possible, such as using the escale key to cancel a change, I think. However, it is a bit confusing and maybe we should reconsider this and see if we can make it work differently. Otherwise, the app needs to listen to all changes, rather than just control invokation.

comment:10 Changed 2 years ago by pulkomandy

Blocking: 13225 removed

(In #13225) It is similar to #10094 and has the same cause (you can't write to read-only files). The ways to solve it may be a little different however, so I'm keeping the two tickets.

Definitely not related to #5812 which is a more specific problem.

Note: See TracTickets for help on using tickets.