Opened 13 years ago

Closed 11 years ago

#852 closed bug (fixed)

[bin:gdb] won't quit correctly

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Steps to reproduce: Start GLTeapot, crash it as described in bug #851 Press debug and then close terminal window. gdb will still be running.

Change History (12)

comment:1 Changed 13 years ago by wkornewald

Milestone: R1
Version: R1 development

comment:2 Changed 13 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev18941 as well; it was the same problem as bug #841.

comment:3 Changed 13 years ago by diver

Resolution: fixed
Status: closedreopened

There is another case when this could happens, see bug #485 to reproduce it.

comment:4 Changed 12 years ago by axeld

I can't reproduce this - does it still happen?

comment:5 Changed 12 years ago by diver

Nope, gdb quits just fine in this case.

comment:6 Changed 12 years ago by axeld

Resolution: fixed
Status: reopenedclosed

comment:7 Changed 12 years ago by diver

Resolution: fixed
Status: closedreopened

It seems that reproducing bug #478 triggered this bug again, reopening.

comment:8 Changed 12 years ago by axeld

Owner: changed from axeld to bonefish
Status: reopenednew

comment:9 Changed 12 years ago by bonefish

Milestone: R1R1/alpha

I can't reproduce the problem described in #478. I also tried a few crash situations, but gdb would always quit properly when closing the Terminal window. The problem might have been fixed by my changes regarding waitpid() or related stuff a few weeks ago. Unless you can still reproduce it, I would close it again.

comment:10 Changed 11 years ago by nielx

Bump.

It has been more than two months. Can this one be closed?

comment:11 Changed 11 years ago by diver

I think so, if i ever manage to reproduce it, i will reopen this ticket.

comment:12 Changed 11 years ago by bonefish

Resolution: fixed
Status: newclosed

Most likely fixed.

Note: See TracTickets for help on using tickets.