Opened 13 years ago

Closed 11 years ago

#271 closed bug (fixed)

drag & drop is broken, can crash or deadlock app_server

Reported by: marcusoverhagen Owned by: mmlr
Priority: blocker Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

Drag & drop is broken and can crash or deadlock the app_server.

Michael Lotz is working on fixing this. See #269 for details.

This affects the following bugreports: #117 #231 #234 #269

Change History (13)

comment:1 Changed 13 years ago by marcusoverhagen

Status: newassigned

comment:2 Changed 13 years ago by marcusoverhagen

blocked: 235

comment:3 Changed 13 years ago by diver

Cc: diver added

comment:4 Changed 13 years ago by mmlr

Simple drag & drop (like moving or dropping Tracker items) should work as of hrev17058. The negotiated drag & drop (making a bitmap clip from ShowImage) still seems to be broken. Note that we do not yet use (the faster) message delivery by shared area. This causes some flattening / unflattening that gives a noticable delay when initiating a drag.

comment:5 Changed 13 years ago by axeld

Are you sure it's caused by that? Usually, drag&drop messages are pretty tiny, and (un)flattening them even hundred times shouldn't be noticeable. (I haven't yet tried it, though :))

comment:6 Changed 13 years ago by mmlr

Under real hardware the delay is not noticeable but under QEMU there is one. Could come from the blending in HWInterface::_AdoptDragBitmap() as well though. The mouse moved message on the other hand certainly suffer from the constant unflattening even of tiny messages.

comment:7 Changed 13 years ago by mmlr

With the BMessage fix in hrev17101 negotiated drag & drop should now work too (making bitmap clips from ShowImage for example). I'll leave this bug open until I verified that there remain no locking issues.

comment:8 Changed 13 years ago by diver

I think there's no locking issues remains. The only thing is that first icon drag after Haiku boot doesn't work. After that everything is okey.

comment:9 Changed 12 years ago by wkornewald

Description: modified (diff)
Platform: All

comment:10 Changed 12 years ago by diver

Aah, there is one locking issue: To reproduce BeMenu->Applications->Zoom button->Alt+a->drag Icon-O-Matic (you should now drag several items. Now start to drag this items around and in the same time swith workspaces using alt+1 alt+2 very fast, after 30-60 sec you can't drop this items and you have to reboot.

comment:11 Changed 12 years ago by aldeck

Can't reproduce any of those bugs here on hrev21836, may need more testing, if there's more specific bugs to test other drag&drop issues should have their own ticket.

comment:12 Changed 11 years ago by mmlr

I haven't encountered drag&drop issues in a while now and all the affected bugs have been closed. Can we therefore agree on closing this ticket too and open up new ones with concrete steps to reproduce when they appear?

comment:13 Changed 11 years ago by axeld

Resolution: fixed
Status: assignedclosed

Agreed.

Note: See TracTickets for help on using tickets.