Opened 9 years ago

Closed 3 months ago

Last modified 3 days ago

#7698 closed enhancement (fixed)

Tracking ticket for missing or incomplete localization

Reported by: taos Owned by: pulkomandy
Priority: normal Milestone: R1/beta3
Component: Kits/Locale Kit Version: R1/Development
Keywords: localization Cc:
Blocked By: Blocking:
Platform: All

Description (last modified by diver)

Localization has come a long way since alpha 2. However, there are still a few things missing. I've collected open tickets concerning localization (bugs and enhancements). Feel free to add missing tickets - or to close this tracking ticket if you think it's not needed.

#5743 Texts in resource file is not localized in Printers preflet
#5817 Locale - Keyboard-Navigation bug.
#6515 language mix due to country settings
#7270 Localizing MediaPlayer's info window
#7293 Untranslated names of file systems in DriveSetup
#7321 FileTypes - Type and Display as not localized
#7491 AboutSystem: clicking on localized license name doesn't open license file
#7506 Filepanels mixing un/localized folder names
#7586 [Terminal] window title and menubar are not localized

Rather general problems attributed to or affecting localization:

#1586 Queries: not case-insensitive for "Umlauts"
#4181 'query' Cannot Parse Dates
#4335 [Interface Kit] menu draw a split second earlier than the contents draw
#4681 linkcatkeys fails when building on PPC
#5582 [AboutSystem] is slow to appear
#6263 Bash ls -Q
#6276 Console backspace doesn't properly handle non-ascii unicode
#6930 Tracker status window problems
#7406 Background preference window become very wide
#7434 Tracker gets in a node monitoring loop
#7454 [liblocale.so]About System, Locale and Time Preferences Apps crash after the start
#7552 [Locale preflet] Default translation of Deskbar and Tracker to on

Demos:

#7530 [Cortex] Cortex is not localized
#7532 [Playground] Playground is not localized

Tracker:

#4962 Localizing parsedate usage for Find panel
#6374 [Tracker] several strings not yet translated (patch)
#7289 Attribute labels not localized
#7521 [Tracker Add-Ons] Tracker Add-Ons menu items are not localized
#7567 [Tracker search] Enable search for localized names

Layout problems in localized version:

#5746 No room for the localized text in double-click test area
#6987 InfoWindow Owner clipped in layout
#7209 Does not work change the color of the font in the Terminal in Polish locale.
#7311 Artifacts in ProcessController
#7332 [ScreenSaver] increase window margins
#7369 [ScreenSaver] localized window is too wide

Non-latin scripts:

#6118 [Patch] WebPositive Fallback fonts enhancement
#6967 haiku needs a better font overlay or fallback mechanism

Keymap dependent problems:

#2499 [Keymap] hotkeys doesn't work with some keymaps
#4891 can't input accented characters using dead keys
#5441 Allocate more positions for dead keys
#7428 Alt-Plus won't work in WebPositive)

CLI applications and tools (AFAIK no decision if they should be translated at all):

#6318 Fixing listport output and changing it to a localized BApplication
#7162 A bitsinfo localization
#7163 A pnginfo localization
#7164 A bmpinfo localization
#7167 A stxtinfo localization
#7168 A tgainfo localization

3rd party applications:

#7210 WebKit and WebPositive localization

Usually not visible (error messages or applications not (yet) included in standard haiku build):

#6109 ResEdit without ResListView.h and ResListView.cpp
#7576 [Locale Kit] localize /src/system/libroot/posix/string/strerror.c

The following tickets might have been (at least partially) fixed in the meantime:

#5471 [Locale] language list is lowercase for some locales
#6369 userguide update issue
#6729 [Locale] add initial scroll to selection
#6747 [BOutlineListView] incorrect behavior observed in Locale preflet's usage of the list view
#6805 [Locale] crashes after pressing Default button
#7240 Localized status messages too big for window)
#7245 Some enchancements and fixing of the Devices application localization
#7393 Minimal width of window

Attachments (1)

0001-Corrected-system-name-translation.patch (656 bytes ) - added by dsjonny 8 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 by taos, 9 years ago

New tickets in June 2011:

#7700 [findutils] find displays question marks instead of cyrillic characters
#7741 Localization: Translated variables in AboutSystem's catkeys

Patches submitted in June 2011 for still open tickets:

#7229

Last edited 9 years ago by pulkomandy (previous) (diff)

comment:2 by taos, 9 years ago

New tickets in July 2011:

#7816 Korean (Hangul) fonts needed.
#7819 Instant change of locale
#7853 diff command fails on UTF8 characters in file names
#7873 B_TRANSLATE("String") between #ifdef and #endif not included in catalogs
#7874 Localization of Decorators

Patches submitted in July 2011 for still open tickets:

#7874

Last edited 9 years ago by taos (previous) (diff)

comment:3 by taos, 9 years ago

New tickets in August 2011:

#7901 [patch] BLocale: B_ERROR gets returned from methods in the BLocale class ambiguously
#7912 [ReadOnlyBootPrompt] Keymap list not localized
#7947 [Time] Calendar doesn't respect current locale's week start day

In August 2011 the following localization related tickets were closed as fixed:

#7947 (in hrev42697, reopened)

Patches submitted in August 2011 for still open tickets:

#7901

Last edited 9 years ago by pulkomandy (previous) (diff)

comment:4 by taos, 9 years ago

New tickets in September 2011:

#7961 Select the right font depending on language
#7964 Apple Aluminum Keyboard Layout files
#7967 Update menu modifier images to more accurately reflect the corresponding key that appears on the keyboard
#7974 latest icu-devel package creates incorrect directory

Patches submitted in September 2011 for still open tickets:

#1735, #7964

Last edited 9 years ago by taos (previous) (diff)

comment:5 by pulkomandy, 9 years ago

Component: - GeneralKits/Locale Kit
Owner: changed from nobody to pulkomandy
Status: newassigned

Thanks for listing them ! I'll have a look when I get some time :)

comment:6 by pulkomandy, 9 years ago

Description: modified (diff)

comment:7 by diver, 9 years ago

Description: modified (diff)

comment:8 by diver, 9 years ago

Description: modified (diff)

comment:9 by taos, 9 years ago

New tickets October 2011 - February 2012:

#8021 ThinkPad Keyboard Layout Files
#8037 The application cannot find/load localization catalog from resource
#8050 Saved queries and query templates messed up when switching locale
#8071 ls bug compairing filenames with certain chars
#8078 Export of user guide broken
#8079 Resource uploading broken
#8092 [fsutil ] OS Name should not be hard-coded in translatable strings
#8098 gcc4 ICU-devel package b0rks install
#8118 [User Documentation Translator] Versioning support
#8124 Regression: Folder names are no longer translated
#8146 FontDemo doesn't support non-ASCII characters.
#8147 New message should not default to CP1252
#8148 The option names in "Modifier Keys" dialog are incorrect
#8149 Modifier key settings are not preserved when changing the keymap
#8192 Incorrect collation in Tracker and Deskbar
#8193 LC_* environment variables are exported incorrectly if country is not chosen in Locale → Formatting
#8251 Adding two localized images that cannot be added via the user guide online tool
#8257 [Locale] Remember time settings
#8284 Pootle & French translation
#8291 Localization site not working 100% with Web+
#8300 CannaIM display problem
#8353 Update Lithuanian keymaps

Patches submitted during that time for still open tickets:

#7767 (patch already applied), #8124, #8300, #8353

Old open (or re-opened) tickets:

#4989 Small changes to the translation panel
#7263 Finnish welcome documentation
#7270 Localizing MediaPlayer's info window (patch included)
#7423 UTF-8 multibyte characters not handled by UTF8Char::IsSpace()

Last edited 9 years ago by taos (previous) (diff)

comment:10 by dsjonny, 8 years ago

The FontDemo's "System name" translation is still missing.

comment:11 by dsjonny, 8 years ago

The mailbox's menu's on the Deskbar's self has missing translations: the "Open Drafts", "Open Inbox Folder" and the "Open Mail Folder". Please correct it.

comment:12 by humdinger, 8 years ago

Fixed FontDemo's "System name" (comment:10)

comment:13 by dsjonny, 8 years ago

patch: 01

comment:14 by dsjonny, 8 years ago

FontDemo: added a patch for system name correction. Tested, works fine (maybe it need to recreate the catalogs).

comment:15 by humdinger, 8 years ago

Applied patch to FontDemo Jamfile with hrev45139. Thanks!

comment:16 by mmadia, 8 years ago

patch: 10

comment:17 by diver, 7 months ago

I think this one can be closed now as most of the bugs are fixed.

comment:18 by diver, 3 months ago

Resolution: fixed
Status: assignedclosed

Most of the tickets here are fixed, the rest (and new ones) can be found using localization keyword.

comment:19 by nielx, 3 days ago

Milestone: R1R1/beta3

Assign fix to milestone:R1/beta3, as it looks like this fix will be part of that release.

As we started with the previous beta, we would like to use the Milestone field for fixed tickets to log from which release the improvement will be out. Therefore it is very much appreciated to assign the milestone when closing a ticket as fixed.

Note: See TracTickets for help on using tickets.